summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-28 11:09:00 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-28 11:58:01 +0100
commitcc4c70c2099d94ee9346279a0341805e08b5dd9e (patch)
tree2caa36e2839634d2735d3caa6e44fa1ea7d7447f /dev-python/snakeoil/snakeoil-9999.ebuild
parentsys-apps/pkgcore: Bump to 0.11.0 (diff)
downloadgentoo-cc4c70c2099d94ee9346279a0341805e08b5dd9e.tar.gz
gentoo-cc4c70c2099d94ee9346279a0341805e08b5dd9e.tar.bz2
gentoo-cc4c70c2099d94ee9346279a0341805e08b5dd9e.zip
dev-python/snakeoil: Modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/snakeoil/snakeoil-9999.ebuild')
-rw-r--r--dev-python/snakeoil/snakeoil-9999.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/dev-python/snakeoil/snakeoil-9999.ebuild b/dev-python/snakeoil/snakeoil-9999.ebuild
index 0c98e3d18348..0a7822decd00 100644
--- a/dev-python/snakeoil/snakeoil-9999.ebuild
+++ b/dev-python/snakeoil/snakeoil-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{8..9} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -19,14 +19,7 @@ HOMEPAGE="https://github.com/pkgcore/snakeoil"
LICENSE="BSD BSD-2 MIT"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-[[ ${PV} == 9999 ]] && DEPEND+=" dev-python/cython[${PYTHON_USEDEP}]"
+[[ ${PV} == 9999 ]] && BDEPEND+=" dev-python/cython[${PYTHON_USEDEP}]"
-python_test() {
- esetup.py test
-}
+distutils_enable_tests pytest