summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-11 10:13:00 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-11 10:59:12 +0100
commit5bc555478d1413c5b0c8afd7980dc26229683004 (patch)
tree3df9426167861be7bebdb7a9a5513596144f0c30 /dev-python/sphinx-autodoc-typehints
parentdev-python/anyio: Bump to 3.5.0 (diff)
downloadgentoo-5bc555478d1413c5b0c8afd7980dc26229683004.tar.gz
gentoo-5bc555478d1413c5b0c8afd7980dc26229683004.tar.bz2
gentoo-5bc555478d1413c5b0c8afd7980dc26229683004.zip
dev-python/sphinx-autodoc-typehints: Bump to 1.15.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.15.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index f517b1be3a5a..7193efdac711 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -4,3 +4,4 @@ DIST sphinx-autodoc-typehints-1.13.1.gh.tar.gz 19923 BLAKE2B d0f72b814c83dd8987b
DIST sphinx-autodoc-typehints-1.14.0.gh.tar.gz 21541 BLAKE2B 77b0e80e5518d64be9dde3d3d2af3d9e0e325daa6683ce8aabe6ac88373ee76e11273b98cf3a18c1391a451354b9cec164c8c14e81354092181b959223500669 SHA512 eba927531b074edd1bf4ce0f3e5af53b07d1be3f013b5f39babc81101b32a942040f7b72380f9f485a99bdb8bfec69f7f81d50b0ceaf73b2859f292e47416d59
DIST sphinx-autodoc-typehints-1.14.1.gh.tar.gz 22095 BLAKE2B 43fff7ad0ce83d4a7b50da7b3d0f9936754cb1897defe5d91bfef44dfae4df7bb6a0472fe5012bd2526a642149710e96b407fee3096dfb1474187273133079be SHA512 a720195d8792f3b6f5b8b5ce84b709872e7034c38640c15ab83b1676b5f0c26c650b0e74c34dbf9652e32f8b7f66edb94dcf4447ff2e0a1b196b721583294f49
DIST sphinx-autodoc-typehints-1.15.1.gh.tar.gz 23279 BLAKE2B 3ba75560111025d2a468572312bd1953315acc55aff4d80f069dcc8fb31fe6253b2dfd3d3f36a75be4dddb3573dd1282d949e5e99df9d4c6cb679c50e7a375d9 SHA512 6cf5750839d550af99ae74c9d31c403aa322108f81b779b8514c90beb315803d5fe550d65bb4cb8861ce224b220ef16b5627198aa0f46b68000c916a2c99983a
+DIST sphinx-autodoc-typehints-1.15.2.gh.tar.gz 23567 BLAKE2B 5febaf00b5d8230196e0c0218b91f82a2a23bac4b3004569f877e55228943e1f25774363a063bfc67bab73d6f92f3a0c6e3a6a473451cee2fec38600962b15b3 SHA512 b200460a50fc4d636365a7438d3a4937592eaf672ccb18c80f5e5a83a64fdaabb1a92d95321edf76ba0fa1ea6b0c66710e6f18ee330631c03c84d3277b2eeeda
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.15.2.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.15.2.ebuild
new file mode 100644
index 000000000000..d294c9d62eb8
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.15.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension "
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+SRC_URI="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+SLOT="0"
+
+RDEPEND=">=dev-python/sphinx-4[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphobjinv[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}