summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-09 21:18:29 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-09 21:19:52 +0100
commitab4c97a307d3e5b4ce959e794cb37f172821d6d8 (patch)
tree3dd76eddefbd007e5584a148b2c465d87aaf2824 /dev-python/sphinx-bootstrap-theme
parentmedia-radio/tucnak: add 4.49 (diff)
downloadgentoo-ab4c97a307d3e5b4ce959e794cb37f172821d6d8.tar.gz
gentoo-ab4c97a307d3e5b4ce959e794cb37f172821d6d8.tar.bz2
gentoo-ab4c97a307d3e5b4ce959e794cb37f172821d6d8.zip
dev-python/sphinx-bootstrap-theme: Build demo for testing
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-bootstrap-theme')
-rw-r--r--dev-python/sphinx-bootstrap-theme/sphinx-bootstrap-theme-0.8.1.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/dev-python/sphinx-bootstrap-theme/sphinx-bootstrap-theme-0.8.1.ebuild b/dev-python/sphinx-bootstrap-theme/sphinx-bootstrap-theme-0.8.1.ebuild
index fd1fab5f0119..7ad4a9965306 100644
--- a/dev-python/sphinx-bootstrap-theme/sphinx-bootstrap-theme-0.8.1.ebuild
+++ b/dev-python/sphinx-bootstrap-theme/sphinx-bootstrap-theme-0.8.1.ebuild
@@ -4,17 +4,27 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
inherit distutils-r1
DESCRIPTION="Sphinx theme integrates the Bootstrap CSS / JavaScript framework"
-HOMEPAGE="https://ryan-roemer.github.io/sphinx-bootstrap-theme/README.html"
+HOMEPAGE="
+ https://ryan-roemer.github.io/sphinx-bootstrap-theme/README.html
+ https://github.com/ryan-roemer/sphinx-bootstrap-theme/
+ https://pypi.org/project/sphinx-bootstrap-theme/
+"
SRC_URI="
- https://github.com/ryan-roemer/${PN}/archive/v${PV}.tar.gz
+ https://github.com/ryan-roemer/sphinx-bootstrap-theme/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ cd demo || die
+ "${EPYTHON}" -m sphinx -d "${BUILD_DIR}"/doctrees \
+ -b html source "${BUILD_DIR}"/html || die
+}