summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-25 08:36:03 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-25 09:45:14 +0200
commit63fdc8dfa3369b282341cc1193990af19120ab05 (patch)
tree789746de5f9af9f3216bf4f78621dac56eb4c1a7 /dev-python/sphinx-gallery
parentapp-admin/awscli: Bump to 1.20.48 (diff)
downloadgentoo-63fdc8dfa3369b282341cc1193990af19120ab05.tar.gz
gentoo-63fdc8dfa3369b282341cc1193990af19120ab05.tar.bz2
gentoo-63fdc8dfa3369b282341cc1193990af19120ab05.zip
dev-python/sphinx-gallery: Bump to 0.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-gallery')
-rw-r--r--dev-python/sphinx-gallery/Manifest1
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.10.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-gallery/Manifest b/dev-python/sphinx-gallery/Manifest
index 9a7d3f3788ea..cdea7600f381 100644
--- a/dev-python/sphinx-gallery/Manifest
+++ b/dev-python/sphinx-gallery/Manifest
@@ -1 +1,2 @@
+DIST sphinx-gallery-0.10.0.tar.gz 6544847 BLAKE2B c7ca0398b4a2c0090a9c6154b7aa068e05d4eef832a756693b07a23902d1c2e54bbcdb19c108a261555a12646b6fc5fa2314e0337ad8637c4d63173338189054 SHA512 9aa56966ec137f678187383440c0949fb1f91e88c66ad297efd48329627b9891c2d668a2472b071d9352cc22d717e41a5088884fa89a26707c5399dca7cc7237
DIST sphinx-gallery-0.9.0.tar.gz 6530860 BLAKE2B 925a745a9bedaa98cf03fbd66bdb87e5c147543a21944d827f738ea1a8bc657a01f0eba2fa5abe64f7bd3632bef604d9490740f2b6fe5100bba92aeb93f3eaf3 SHA512 e511100c5add06de681b0682c90b3e914d49625c63391896dfdec8e6f6f378cfc65fc3425d4216ee0ebbdd4feb3397517ca40a838947b31257654fff2b8a7e8a
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.10.0.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.10.0.ebuild
new file mode 100644
index 000000000000..01bce9304f3b
--- /dev/null
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.10.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
+HOMEPAGE="
+ https://sphinx-gallery.github.io/
+ https://github.com/sphinx-gallery/sphinx-gallery"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/joblib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov-report= --cov=sphinx_gallery::' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+EPYTEST_DESELECT=(
+ # Internet
+ sphinx_gallery/tests/test_docs_resolv.py::test_embed_code_links_get_data
+ sphinx_gallery/tests/test_full.py::test_run_sphinx
+ sphinx_gallery/tests/test_full.py::test_embed_links_and_styles
+)