summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-05-06 15:39:26 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-06 17:16:23 -0700
commit4751e4e1f2b0405fd33770ad247363f3656d0d15 (patch)
treed7b0f585a6a1ad0949ebddea5bedf9fd0ed04aa4 /dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.7.0.ebuild
parentdev-python/astunparse-1.6.2: enable tests, add py38 (diff)
downloadgentoo-4751e4e1f2b0405fd33770ad247363f3656d0d15.tar.gz
gentoo-4751e4e1f2b0405fd33770ad247363f3656d0d15.tar.bz2
gentoo-4751e4e1f2b0405fd33770ad247363f3656d0d15.zip
dev-python/sphinxcontrib-httpdomain-1.7.0: bump, enable tests, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.7.0.ebuild')
-rw-r--r--dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.7.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.7.0.ebuild b/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.7.0.ebuild
new file mode 100644
index 000000000000..129a707fd966
--- /dev/null
+++ b/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.7.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extension providing a Sphinx domain for describing RESTful HTTP APIs"
+HOMEPAGE="https://github.com/sphinx-contrib/httpdomain
+ https://sphinxcontrib-httpdomain.readthedocs.io/"
+SRC_URI="https://github.com/sphinx-contrib/httpdomain/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN#sphinxcontrib-}-${PV}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}