summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-09 17:42:32 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-09 17:42:32 +0200
commit27693b43cc22c7815442b033e5b3e4d89e44a0f6 (patch)
tree0002a0e2e10677f4addaa08ca6e552ff1832c473 /dev-python/sphinxcontrib-trio
parentdev-python/sphinx-panels: update EAPI 7 -> 8, pep517, py3.12 (diff)
downloadgentoo-27693b43cc22c7815442b033e5b3e4d89e44a0f6.tar.gz
gentoo-27693b43cc22c7815442b033e5b3e4d89e44a0f6.tar.bz2
gentoo-27693b43cc22c7815442b033e5b3e4d89e44a0f6.zip
dev-python/sphinxcontrib-trio: pep517
Closes: https://bugs.gentoo.org/909968 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-trio')
-rw-r--r--dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2-r1.ebuild b/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..c6ed42088b64
--- /dev/null
+++ b/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Make Sphinx better at documenting Python functions and methods"
+HOMEPAGE="
+ https://github.com/python-trio/sphinxcontrib-trio
+ https://pypi.org/project/sphinxcontrib-trio/
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ test? (
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+)"
+
+# AttributeError: 'Sphinx' object has no attribute 'add_stylesheet'
+#distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_test() {
+ # https://github.com/python-trio/sphinxcontrib-trio/issues/260
+ local -x PYTHONPATH="${BUILD_DIR}/install/usr/lib/${EPYTHON}/site-packages"
+ epytest --deselect tests/test_sphinxcontrib_trio.py::test_end_to_end
+}