summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-07 06:32:28 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-07 06:32:28 +0100
commitf0bafa4c3bff517383b779b2bd917999d0592922 (patch)
tree939b88555f192bba16769c1e165344f5f4873575 /dev-python/statsd
parentdev-python/platformdirs: Bump to 2.5.3 (diff)
downloadgentoo-f0bafa4c3bff517383b779b2bd917999d0592922.tar.gz
gentoo-f0bafa4c3bff517383b779b2bd917999d0592922.tar.bz2
gentoo-f0bafa4c3bff517383b779b2bd917999d0592922.zip
dev-python/statsd: Bump to 4.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/statsd')
-rw-r--r--dev-python/statsd/Manifest1
-rw-r--r--dev-python/statsd/statsd-4.0.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/statsd/Manifest b/dev-python/statsd/Manifest
index 2d6c5526e7af..3404f315644b 100644
--- a/dev-python/statsd/Manifest
+++ b/dev-python/statsd/Manifest
@@ -1,2 +1,3 @@
DIST statsd-3.3.0.tar.gz 259045 BLAKE2B 015eb32d40d1eb45d64266f0bd62d9496a7eb8815dccf4ad482bb3b81b45fceef14a25893b05ad3b5a8da8582434a46725598a90ebd06c6120dac32169a1f201 SHA512 e2693bc7f179e275c53044d13a4685dd72ebd47adafcab5064e803fbf9e8df4a0f20f61c3695846d3c33178be17dd7286f487213fa2bd8545ed1612e200c8f36
DIST statsd-4.0.0.tar.gz 27793 BLAKE2B 9ba08458ecfaa9f5cf3a981eee06abec72b9d8c3a49869ae67be0863799f1198dd915c3b351d5f75404d649a832af17fe1f60346e47863f238dd65ed4a96a9f2 SHA512 e4bc232b755ba439a5401edca2b9d5f1b66b04b6ee20c46ab8da8c38a718437e1010809bae4479da8cda8323e40203cc3b9952a40df187bf1c73fd2ffdf3da8d
+DIST statsd-4.0.1.tar.gz 27814 BLAKE2B 18e7d1c0e4701e53972cf0f7f8fb7f4d17e41023019a642e609fc86537a6f51cd89da8d4e725ffaf5328f7d4a2a41034676f419856d0da0bbeb9915751b81eff SHA512 1a9aa4ba810aa75b3235e6357b820d8987ffe4ed55709929a9a53c6ced587525217e55754600f9c5596ea1e5fd26a0ea15b643199aa39e920d95120e22fc2ae0
diff --git a/dev-python/statsd/statsd-4.0.1.ebuild b/dev-python/statsd/statsd-4.0.1.ebuild
new file mode 100644
index 000000000000..b92830f6e6a2
--- /dev/null
+++ b/dev-python/statsd/statsd-4.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple statsd client"
+HOMEPAGE="
+ https://github.com/jsocol/pystatsd/
+ https://pypi.org/project/statsd/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest statsd/tests.py
+}