summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-12 04:25:08 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-12 04:25:08 +0200
commitc51d7ce8a7192041aa523feb90deb804e9308b76 (patch)
treed4dbfc858707957f00ffec85205a383936f3b12b /dev-python/stripe
parentdev-python/cfn-lint: Bump to 1.6.0 (diff)
downloadgentoo-c51d7ce8a7192041aa523feb90deb804e9308b76.tar.gz
gentoo-c51d7ce8a7192041aa523feb90deb804e9308b76.tar.bz2
gentoo-c51d7ce8a7192041aa523feb90deb804e9308b76.zip
dev-python/stripe: Bump to 10.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/stripe')
-rw-r--r--dev-python/stripe/Manifest1
-rw-r--r--dev-python/stripe/stripe-10.3.0.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/stripe/Manifest b/dev-python/stripe/Manifest
index 7236cbd74420..5273de8758bd 100644
--- a/dev-python/stripe/Manifest
+++ b/dev-python/stripe/Manifest
@@ -1,4 +1,5 @@
DIST stripe-10.0.0.tar.gz 1284985 BLAKE2B c2cde142b324fb622c7b7c3b967d01caf3a31c7832825b750e88ff7a4b8b41efe457c40ce329977f7df39b54ecf267812174a31682106aaecda78ebe53322467 SHA512 fa72997cde84a7fd871e9be53a560bce07041dddd9db7e37942b1c7cfaee8c2fd3a671f08f1b567b60aee017f7a6b9662dd2cfb3a06036bd9b0f3a03a395e0df
DIST stripe-10.1.0.tar.gz 1290758 BLAKE2B 0ec51d9189b1d574eb1eb2eb7c3683b2b6b86c9879445c2de60da1a16684e0fe095abbe841cc59ea8daad6862d864550bfb5a9c9dd6a034df42a01c8ec59be4c SHA512 ecac8856ce6993ba5c339a44791b9197f2e1b8a62292d5e9e555e02004007ad90c400dff8d111df2ae1428436ba413a47b59ef9b5e9da445872495c45aa844c3
DIST stripe-10.2.0.tar.gz 1297807 BLAKE2B 996636c7cca85295c7fbf5ec108cb6b62db11ebc26d8978329c437b55d5f15bd15936c1386a915deb9544bf4f5869440e13fc307962e1b796a7901b10d406595 SHA512 83ae38e4f53302fd16f1dce10f6e4336842ee81bbab272ebd9362e7bd0c7b03168e6de2ff14a0f2cbd332eaba9ed8dc2bf24894cfd5600d8a91cb5670c477fbe
+DIST stripe-10.3.0.tar.gz 1300786 BLAKE2B 626a3c52cbb93aeae3749f6ffedd421557aa4e8085d2b0591ca2c1c866caa64ef78bdf8f0e5c85ee814ffd588d95ee05267748a97f2a50ff89d28a9e501d4da8 SHA512 7353df871f0b83330208e1a3e0fa339d319c3bb1b2e4e90bf045dd691120b22b908e263f3cdae5127b3a1299b950be3685ec631492888884d42570947de70268
DIST stripe-9.12.0.tar.gz 1277151 BLAKE2B a23e490ac99f3814db204cd8ad71793b5da73a82c420823cecd87dad5f17c9dbe44a7dcdfbb519b5db4cb488f286e231029827bae25657c2bf4183d1c4dd8406 SHA512 c6c4a4cfeddda4c0e4042b31addea6885819304b469e4f7f701c894fca2d1ccca867dac511abf8d9dd9fc7cc135185387a5b55d37558b9355ee4add16b6318cb
diff --git a/dev-python/stripe/stripe-10.3.0.ebuild b/dev-python/stripe/stripe-10.3.0.ebuild
new file mode 100644
index 000000000000..7925c1fc5c50
--- /dev/null
+++ b/dev-python/stripe/stripe-10.3.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Stripe Python bindings"
+HOMEPAGE="
+ https://github.com/stripe/stripe-python/
+ https://pypi.org/project/stripe/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="telemetry"
+
+RDEPEND="
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.5.0[${PYTHON_USEDEP}]
+"
+# please bump dev-util/stripe-mock dep to the latest version on every bump
+BDEPEND="
+ test? (
+ >=dev-util/stripe-mock-0.186.0
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/anyio[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ net-misc/curl
+ )
+"
+
+distutils_enable_tests pytest
+
+DOCS=( LONG_DESCRIPTION.rst CHANGELOG.md README.md )
+
+src_prepare() {
+ if ! use telemetry; then
+ sed -i -e '/enable_telemetry/s:True:False:' stripe/__init__.py || die
+ fi
+ # https://github.com/stripe/stripe-python/pull/1297
+ sed -e 's:from mock:from unittest.mock:' \
+ -i tests/test_http_client.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests -p anyio -p pytest_mock
+}
+
+src_test() {
+ local stripe_mock_port=12111
+ local stripe_mock_max_port=12121
+ local stripe_mock_logfile="${T}/stripe_mock_${EPYTHON}.log"
+ # Try to start stripe-mock until we find a free port
+ while [[ ${stripe_mock_port} -le ${stripe_mock_max_port} ]]; do
+ ebegin "Trying to start stripe-mock on port ${stripe_mock_port}"
+ stripe-mock --http-port "${stripe_mock_port}" &> "${stripe_mock_logfile}" &
+ local stripe_mock_pid=${!}
+ sleep 2
+ # Did stripe-mock start?
+ curl --fail -u "sk_test_123:" \
+ "http://127.0.0.1:${stripe_mock_port}/v1/customers" &> /dev/null
+ eend ${?} "Port ${stripe_mock_port} unavailable"
+ if [[ ${?} -eq 0 ]]; then
+ einfo "stripe-mock running on port ${stripe_mock_port}"
+ break
+ fi
+ (( stripe_mock_port++ ))
+ done
+ if [[ ${stripe_mock_port} -gt ${stripe_mock_max_port} ]]; then
+ eerror "Unable to start stripe-mock for tests"
+ die "Please see the logfile located at: ${stripe_mock_logfile}"
+ fi
+
+ local -x STRIPE_MOCK_PORT=${stripe_mock_port}
+ distutils-r1_src_test
+
+ # Tear down stripe-mock
+ kill "${stripe_mock_pid}" || die "Unable to stop stripe-mock"
+}