summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-11-28 11:58:02 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-29 09:16:15 +0100
commitf11afffc9b087b874262ab5c0ec64fade1867d38 (patch)
tree3eeb7a233ba34a8d4d344d6da96cf8cbb00d85dd /dev-python/superlance
parentmedia-libs/libopenshot-audio: fix dependencies (diff)
downloadgentoo-f11afffc9b087b874262ab5c0ec64fade1867d38.tar.gz
gentoo-f11afffc9b087b874262ab5c0ec64fade1867d38.tar.bz2
gentoo-f11afffc9b087b874262ab5c0ec64fade1867d38.zip
dev-python/superlance: bump to 1.0.0
Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/2942
Diffstat (limited to 'dev-python/superlance')
-rw-r--r--dev-python/superlance/Manifest1
-rw-r--r--dev-python/superlance/metadata.xml1
-rw-r--r--dev-python/superlance/superlance-1.0.0.ebuild41
3 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/superlance/Manifest b/dev-python/superlance/Manifest
index 6a5a63830c1b..db35ee9ecca3 100644
--- a/dev-python/superlance/Manifest
+++ b/dev-python/superlance/Manifest
@@ -1,2 +1,3 @@
DIST superlance-0.13.tar.gz 35009 SHA256 51fb4c990ed6dda553fbc541c5d638b614dfd8bd2832a3d958300c75dc2bf83a SHA512 283a49f345901c9212b4fa44b6cf47590c70ee9861bcedaf5c85ef74b445998e890daf9aa2d45ca32e66e8b41d9ca54eb12d860403c536265415e473dc8a2ffc WHIRLPOOL c8203367bec0f8c14c1b28607a5cd77f65a0d34a07f09bd32127fcc0dbbde280a9ff0bdfffe113c1122deb9a16225e9d9df60ad8aa616942fe042ca2e5e5749e
DIST superlance-0.14.tar.gz 36237 SHA256 74bba9be799a3eacb4120f05d2999d401365527f3cd0e924f68b6e475367c987 SHA512 41fdc9cf83ce636aea3665aed0fa9b1a37c2fe4d3740db694c20f60676d44ee6cc534ae038018edc0a1057607bac9dd4f0d14ea365735148a19a10e138723efd WHIRLPOOL b11f7eaf04f108b9183cbdb2f6ab329bd663fb8a1a1845c6e949f1e3b1fe32550ca432990203f2274fb4bc33145047f9b446d3bf181233bff6df34f32f9ae0c8
+DIST superlance-1.0.0.tar.gz 36909 SHA256 f697c71341e9a686f3a0ff3f04a82448523eac0a6121484933729ba65a973a63 SHA512 f85dbd0768820e2f679b374c5178e6b74de21cebd813a485f615203784e25a968ddcbae72cae41dc56f4f105dab9a6ead16acf4d4cffa3cf30d91650ebb20611 WHIRLPOOL 87b5d3df4d426bced16a2c82f4383e904b91a7905d0f5193c716b989b4a2abe34eea712ef30e4721654787260bbc560108438322cf929d287b6374b4df30185d
diff --git a/dev-python/superlance/metadata.xml b/dev-python/superlance/metadata.xml
index 6032000b3efd..6417ec325937 100644
--- a/dev-python/superlance/metadata.xml
+++ b/dev-python/superlance/metadata.xml
@@ -4,7 +4,6 @@
<maintainer type="person">
<email>sautier.louis@gmail.com</email>
<name>Louis Sautier</name>
- <description>Proxied maintainer; set to assignee in all bugs</description>
</maintainer>
<maintainer type="project">
<email>proxy-maint@gentoo.org</email>
diff --git a/dev-python/superlance/superlance-1.0.0.ebuild b/dev-python/superlance/superlance-1.0.0.ebuild
new file mode 100644
index 000000000000..30f77daf97f1
--- /dev/null
+++ b/dev-python/superlance/superlance-1.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A set of plugins to monitor and control supervisor"
+HOMEPAGE="https://github.com/Supervisor/superlance"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="app-admin/supervisor[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}