summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-19 07:48:29 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-19 09:14:53 +0200
commit75d1e273cc6f7525d88e93075378f2fbf775c69b (patch)
tree7b68aaef3e56d20348347d784bd92740a66532f7 /dev-python/svglib
parentdev-python/reportlab: Enable py3.11 (diff)
downloadgentoo-75d1e273cc6f7525d88e93075378f2fbf775c69b.tar.gz
gentoo-75d1e273cc6f7525d88e93075378f2fbf775c69b.tar.bz2
gentoo-75d1e273cc6f7525d88e93075378f2fbf775c69b.zip
dev-python/svglib: Bump to 1.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/svglib')
-rw-r--r--dev-python/svglib/Manifest1
-rw-r--r--dev-python/svglib/svglib-1.3.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/svglib/Manifest b/dev-python/svglib/Manifest
index 6266be312ce5..1a69a7b31d9f 100644
--- a/dev-python/svglib/Manifest
+++ b/dev-python/svglib/Manifest
@@ -1 +1,2 @@
DIST svglib-1.2.1.gh.tar.gz 1261918 BLAKE2B d2c35dfbd45f3c509674e0aa49d015ddc554d1e9d2ccf584a5ada019d9af5e7ee2ccf8c983c30e9107cb83468db6521153fa8340f0dab3b4b1ae5a839628e186 SHA512 361dec376eec6ed9bc52e2217a28e09bcfaab8e302c4ee574a320a8f84963852cfc10d3f6890d379f624a5855122f869eb9698fab89d76018af7bbf70aa587bd
+DIST svglib-1.3.0.gh.tar.gz 1264820 BLAKE2B f53bda781479ddc5d4b04fd122b5141620db81756308973cb283957615711e62623baa74b69af954936be24970a4e4a6f026667c4069d62bf1705a839ecc52f3 SHA512 457fb69ba1c298079888f200502c7099cf5ee674857ff8682948011bf8e1544715e6196544212f5c0ddef1202d04f3f05d01edb4351e673ceae16a85ca0d66e5
diff --git a/dev-python/svglib/svglib-1.3.0.ebuild b/dev-python/svglib/svglib-1.3.0.ebuild
new file mode 100644
index 000000000000..b7b7af262730
--- /dev/null
+++ b/dev-python/svglib/svglib-1.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python library for reading and converting SVG"
+HOMEPAGE="
+ https://github.com/deeplook/svglib/
+ https://pypi.org/project/svglib/
+"
+SRC_URI="
+ https://github.com/deeplook/svglib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/cssselect2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Needs network access
+ tests/test_samples.py::TestWikipediaFlags::test_convert_pdf
+ tests/test_samples.py::TestW3CSVG::test_convert_pdf_png
+)