summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-01 05:32:52 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-01 05:47:46 +0100
commit82284e35b83c04ddf4136085774c507baf8b1acd (patch)
tree54cda3f7d1d2eae99e4243f58a0e981ec000fb19 /dev-python/sybil
parentdev-python/ipython: Bump to 8.21.0 (diff)
downloadgentoo-82284e35b83c04ddf4136085774c507baf8b1acd.tar.gz
gentoo-82284e35b83c04ddf4136085774c507baf8b1acd.tar.bz2
gentoo-82284e35b83c04ddf4136085774c507baf8b1acd.zip
dev-python/sybil: Bump to 6.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest1
-rw-r--r--dev-python/sybil/sybil-6.0.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index ef976f0a27d4..8ccec810aac4 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1 +1,2 @@
DIST sybil-6.0.2.gh.tar.gz 67619 BLAKE2B ec723cb21d2ac1232bd6e9a3e3edb0bc65c705048c2d288df778b4dd19a1b46c956f7d2bd57dfa028d7a8a06357501ffc1226ba171e2073abec51f8d3c536d86 SHA512 9966173b5fb013be1f298b586052d8c10b76efb43bf5230f3d0b780e6d6238e7e33840eeb7c8b9860911351ea612766ed19ea2a61d48424465f3b58e408da5d2
+DIST sybil-6.0.3.gh.tar.gz 67772 BLAKE2B e90b7a01373d931ca056bfce1336bab8a579a25e17000675d77cd849081275970b455c7bc77f30e0fd104073115915fc4f4477b010eafd35e57aec322fb42fc4 SHA512 1fb42b944b237556012ace6fcc5eb3d0f067f0ca043ceafa0e201a8076870fc7e06ae62813eec90d486de6e4b71ebf29176dfff6573de423480c688ff005004d
diff --git a/dev-python/sybil/sybil-6.0.3.ebuild b/dev-python/sybil/sybil-6.0.3.ebuild
new file mode 100644
index 000000000000..dfd594060e6f
--- /dev/null
+++ b/dev-python/sybil/sybil-6.0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}