summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-27 14:05:12 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-27 14:05:12 +0200
commit848165229245c6b0584929c4e7645e9046ea5b2e (patch)
tree74469e94c54790a29263f41ae4f66ce0d07a0a23 /dev-python/sympy
parentdev-python/python-lsp-black: Remove old (diff)
downloadgentoo-848165229245c6b0584929c4e7645e9046ea5b2e.tar.gz
gentoo-848165229245c6b0584929c4e7645e9046ea5b2e.tar.bz2
gentoo-848165229245c6b0584929c4e7645e9046ea5b2e.zip
dev-python/sympy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sympy')
-rw-r--r--dev-python/sympy/Manifest1
-rw-r--r--dev-python/sympy/files/sympy-1.11-no-deprecated-threading-event-api.patch54
-rw-r--r--dev-python/sympy/sympy-1.11.1-r2.ebuild70
3 files changed, 0 insertions, 125 deletions
diff --git a/dev-python/sympy/Manifest b/dev-python/sympy/Manifest
index c1bab91286e0..f19c73e34f72 100644
--- a/dev-python/sympy/Manifest
+++ b/dev-python/sympy/Manifest
@@ -1,2 +1 @@
-DIST sympy-1.11.1.gh.tar.gz 13462495 BLAKE2B a45320d087057595d3574490c6dc07bcdf7870543e9adcbaca9abe293d84875c123bbc91a7263a87b0b71568dece4e1304b6bf76f60ae64e353520f0ca686b1f SHA512 6cc720b673cf31a2e8f56a5cae24ec15024ea43dee92196adb0a87f28561b5d2404fbbfd3d55a8414930a31d4d0f4a731d458ad528c8cbb03c37555f5c14ce4a
DIST sympy-1.12.gh.tar.gz 7212937 BLAKE2B 1d37a019e7a6700e69e16d6ca7fdc563711165fc226ac6ec745d20fa6dc689ee9ea01a92549d851aacff763230872c2d1d0cb5bde581c4f960f5de515ffb5f06 SHA512 96a89b88f6912d70c56f5bd1903dd3c518963118ff25d033cdcb7da2f260b8ee209d3ab4a4394dd2b5dc0b4585b71ccd55d55c8e5c6e28024cccbedf07ee4360
diff --git a/dev-python/sympy/files/sympy-1.11-no-deprecated-threading-event-api.patch b/dev-python/sympy/files/sympy-1.11-no-deprecated-threading-event-api.patch
deleted file mode 100644
index eaffd3f1fbe1..000000000000
--- a/dev-python/sympy/files/sympy-1.11-no-deprecated-threading-event-api.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-Patch back-ported from the sympy git repo
-url: https://github.com/sympy/sympy/commit/b89ca436cf25e2a1caf82c9d33221d06698d0ff5
-
-commit b89ca436cf25e2a1caf82c9d33221d06698d0ff5
-Author: Chris Kerr <chris.kerr@mykolab.ch>
-Date: Thu Sep 22 19:32:27 2022 +0300
-
- Replace deprecated .isSet() method with .is_set()
-
- Fixes https://github.com/sympy/sympy/issues/24074
-
-diff --git a/sympy/plotting/pygletplot/plot_mode_base.py b/sympy/plotting/pygletplot/plot_mode_base.py
-index c1c2b0a6ec..2c6503650a 100644
---- a/sympy/plotting/pygletplot/plot_mode_base.py
-+++ b/sympy/plotting/pygletplot/plot_mode_base.py
-@@ -269,7 +269,7 @@ def _calculate_all(self):
- self._calculate_cverts()
-
- def _calculate_verts(self):
-- if self._calculating_verts.isSet():
-+ if self._calculating_verts.is_set():
- return
- self._calculating_verts.set()
- try:
-@@ -280,9 +280,9 @@ def _calculate_verts(self):
- self.bounds_callback()
-
- def _calculate_cverts(self):
-- if self._calculating_verts.isSet():
-+ if self._calculating_verts.is_set():
- return
-- while self._calculating_cverts.isSet():
-+ while self._calculating_cverts.is_set():
- sleep(0) # wait for previous calculation
- self._calculating_cverts.set()
- try:
-@@ -291,7 +291,7 @@ def _calculate_cverts(self):
- self._calculating_cverts.clear()
-
- def _get_calculating_verts(self):
-- return self._calculating_verts.isSet()
-+ return self._calculating_verts.is_set()
-
- def _get_calculating_verts_pos(self):
- return self._calculating_verts_pos
-@@ -300,7 +300,7 @@ def _get_calculating_verts_len(self):
- return self._calculating_verts_len
-
- def _get_calculating_cverts(self):
-- return self._calculating_cverts.isSet()
-+ return self._calculating_cverts.is_set()
-
- def _get_calculating_cverts_pos(self):
- return self._calculating_cverts_pos
diff --git a/dev-python/sympy/sympy-1.11.1-r2.ebuild b/dev-python/sympy/sympy-1.11.1-r2.ebuild
deleted file mode 100644
index 4f8d6e3f0041..000000000000
--- a/dev-python/sympy/sympy-1.11.1-r2.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Computer Algebra System in pure Python"
-HOMEPAGE="https://www.sympy.org/"
-SRC_URI="https://github.com/sympy/sympy/archive/${P}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}/${PN}-${P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~loong ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="aesara examples imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs"
-
-RDEPEND="
- dev-python/mpmath[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- aesara? ( $(python_gen_cond_dep 'dev-python/aesara[${PYTHON_USEDEP}]' python3_{9..10}) )
- imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
- ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
- latex? (
- virtual/latex-base
- dev-texlive/texlive-fontsextra
- png? ( app-text/dvipng )
- pdf? ( app-text/ghostscript-gpl )
- )
- mathml? ( dev-python/lxml[${PYTHON_USEDEP}] )
- opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
- pyglet? ( dev-python/pyglet[${PYTHON_USEDEP}] )
- symengine? ( dev-python/symengine[${PYTHON_USEDEP}] )
- texmacs? ( app-office/texmacs )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.11-no-deprecated-threading-event-api.patch"
-)
-
-distutils_enable_tests pytest
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- local DOCS=( AUTHORS README.md )
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-
- if use texmacs; then
- exeinto /usr/libexec/TeXmacs/bin/
- doexe data/TeXmacs/bin/tm_sympy
- insinto /usr/share/TeXmacs/plugins/sympy/
- doins -r data/TeXmacs/progs
- fi
-}