summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-20 14:23:44 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-20 14:26:40 +0200
commitc1427e201cb1774b9638c914fd7ed0b4a2d99b9e (patch)
treea8452814bc18808611f6a02d496150775f0ccd73 /dev-python/testfixtures
parentapp-office/lyx: drop 2.3.6.1-r2 (diff)
downloadgentoo-c1427e201cb1774b9638c914fd7ed0b4a2d99b9e.tar.gz
gentoo-c1427e201cb1774b9638c914fd7ed0b4a2d99b9e.tar.bz2
gentoo-c1427e201cb1774b9638c914fd7ed0b4a2d99b9e.zip
dev-python/testfixtures: Bump to 7.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/Manifest1
-rw-r--r--dev-python/testfixtures/testfixtures-7.2.2.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index fdcbfa1416a5..47d4a79ec6e1 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -1 +1,2 @@
DIST testfixtures-7.2.0.tar.gz 133487 BLAKE2B f5c4ff354d1e2b06a28a947fffe8622e51ed680a29ed6fa3ff5e7e851c21e39ed432d6dc0f5f8c83c6541b0054ca3b2afce960f4a00e1e70619a29f29e03b5ae SHA512 b1b5fdd45509e60db8590ec454659efa42c87f75de9187286d820b5643388f83919ccf3763ec223018a5a5b48821041494982af2016c41e11fe30cabdb909223
+DIST testfixtures-7.2.2.tar.gz 133809 BLAKE2B 6a3701bb9c5ca476aadc144f1013268f87e10dd47a6f757e8a0aaa3feb33e1a06663a38f0789b7c54cf439b07562dfb638bd9b89efdc36831d04977f6035ecc8 SHA512 4f7a5ed659b650080deac0b1caff6d2dff0b71d23eaeb26b48b7daa4df85dc0a1f6cfef98275c9a90289eb893c0a06311c849b84f2cc35447fb766f4d0d41c89
diff --git a/dev-python/testfixtures/testfixtures-7.2.2.ebuild b/dev-python/testfixtures/testfixtures-7.2.2.ebuild
new file mode 100644
index 000000000000..b5276e04b446
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-7.2.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="
+ https://pypi.org/project/testfixtures/
+ https://github.com/Simplistix/testfixtures/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/sybil[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/furo
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTHONPATH="."
+ local -x DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings
+
+ local EPYTEST_DESELECT=(
+ # TODO
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_missing
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_present
+ )
+
+ case ${EPYTHON} in
+ python3.12)
+ EPYTEST_DESELECT+=(
+ # https://github.com/simplistix/testfixtures/issues/183
+ docs/comparing.txt::line:790,column:1
+ docs/comparing.txt::line:829,column:1
+ testfixtures/tests/test_tempdirectory.py::TempDirectoryTests::test_as_path_relative_sequence
+ testfixtures/tests/test_tempdirectory.py::TempDirectoryTests::test_as_path_relative_string
+ )
+ ;;
+ esac
+
+ epytest
+}