summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-17 11:51:57 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-17 14:35:13 +0200
commit1d695d91094443b072b7806225b391a84cb45d7a (patch)
tree0d9a77209ffe0a2aed0a37f91f84d33cfa80e7d1 /dev-python/textdistance
parentdev-python/sabctools: Bump to 8.2.4 (diff)
downloadgentoo-1d695d91094443b072b7806225b391a84cb45d7a.tar.gz
gentoo-1d695d91094443b072b7806225b391a84cb45d7a.tar.bz2
gentoo-1d695d91094443b072b7806225b391a84cb45d7a.zip
dev-python/textdistance: Bump to 4.6.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/textdistance')
-rw-r--r--dev-python/textdistance/Manifest1
-rw-r--r--dev-python/textdistance/textdistance-4.6.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/textdistance/Manifest b/dev-python/textdistance/Manifest
index 49bb4897b572..f480ccbdbe2a 100644
--- a/dev-python/textdistance/Manifest
+++ b/dev-python/textdistance/Manifest
@@ -1 +1,2 @@
DIST textdistance-4.6.2.gh.tar.gz 46619 BLAKE2B 0a205bd5615f252f4ab832597b26cd81f3a817fa9544675b947b2ba8a9d8c128ad261a09fb1ee118e0ca807ff7721f3594de5da11f5df59c90c2d9b7110b84ff SHA512 4e5ec7ef76cfd45b05f5813d624d934a6aa90c326b8bc1af50fdde51c4fda141d5aa826e7a145f4cf59f7d7cbcdcf775746eeb197a2adef3c62ad8570d699890
+DIST textdistance-4.6.3.gh.tar.gz 46631 BLAKE2B 9d4c2172934ba14326fe8ecdf7e955cd664196e58d8cc0c58f712525e6ea3aaa267879c09ba5a67ab015f6abd37593af959f02262c5a4a2fa08a859fe38a52b4 SHA512 ad9b8e031a8ae11dd2cd0f8ee8ee42f15e14eccc05910a45b4b5bf2f2048c4895da354832f88957502998b423616a54e64b94a093e4ddb7be2744c19e7f283e9
diff --git a/dev-python/textdistance/textdistance-4.6.3.ebuild b/dev-python/textdistance/textdistance-4.6.3.ebuild
new file mode 100644
index 000000000000..cbe654456441
--- /dev/null
+++ b/dev-python/textdistance/textdistance-4.6.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Compute distance between the two texts"
+HOMEPAGE="
+ https://github.com/life4/textdistance/
+ https://pypi.org/project/textdistance/
+"
+SRC_URI="
+ https://github.com/life4/textdistance/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/test_external.py
+)