summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-19 21:14:17 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-19 21:28:09 +0300
commitc541e798e52c0496fed406c377280b0647176e7d (patch)
tree3d851b61f40b93955bc51767e3cb03b624ca6ef6 /dev-python/textdistance
parentdev-python/pyfakefs: add 4.7.0 (diff)
downloadgentoo-c541e798e52c0496fed406c377280b0647176e7d.tar.gz
gentoo-c541e798e52c0496fed406c377280b0647176e7d.tar.bz2
gentoo-c541e798e52c0496fed406c377280b0647176e7d.zip
dev-python/textdistance: add 4.5.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/textdistance')
-rw-r--r--dev-python/textdistance/Manifest1
-rw-r--r--dev-python/textdistance/textdistance-4.5.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/textdistance/Manifest b/dev-python/textdistance/Manifest
index 5285d235604b..17f12744844f 100644
--- a/dev-python/textdistance/Manifest
+++ b/dev-python/textdistance/Manifest
@@ -1,2 +1,3 @@
DIST textdistance-4.3.0.gh.tar.gz 45535 BLAKE2B e43ae62b0b7656a6c4f879b1d8e0c34ae6c83705d324aa99bb7ff6e2d0166faf1fed3ee7bc06602388c16c742a1983a4eaee143b09a7c371b9e941d53edca2b5 SHA512 30d68048b1f0b79e584f5f07731e03193af64cb2de3f52882c17154cc027f4ff8d590b994941bd5d62642d4da334ef0739d4bb65b6b12f039a1ee9aef154cde4
DIST textdistance-4.4.0.gh.tar.gz 45542 BLAKE2B ae144cb7179b589f4106ea378e538e0d0240e6e2ac74dc5de8222ec2f671fcd09c4705cb5b30308fdb2f6071578d337c0f88983511229d9f7eb86c924d65bf56 SHA512 727696b76ee8fdfc9bcf028a93baad38882893f62612fa08725e5e8cd104b9450977e3682995c4aa7d997afcc8fdb73e3c72ea6c1a097a9a19dbce98957d4798
+DIST textdistance-4.5.0.gh.tar.gz 46674 BLAKE2B 5bac2690c48fc518b56f7d781803684c1ccccbb54e62c613f87a58f2acf81d28b405be5ffc41c7a304e62bd19732cdf99a03816c00765698439073b76c5be6c0 SHA512 ae51a2a0b69acd5fd64cab9509ad58713044a1307eee884ecf00508f406a9442414b1d8c71798f2c3ed0e9f5b22cca0a467f6d5a5928510adda43c6997ea497c
diff --git a/dev-python/textdistance/textdistance-4.5.0.ebuild b/dev-python/textdistance/textdistance-4.5.0.ebuild
new file mode 100644
index 000000000000..427ee9e48841
--- /dev/null
+++ b/dev-python/textdistance/textdistance-4.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Compute distance between the two texts"
+HOMEPAGE="https://github.com/life4/textdistance"
+SRC_URI="
+ https://github.com/life4/textdistance/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/abydos[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/jellyfish[${PYTHON_USEDEP}]
+ dev-python/Levenshtein[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyxDamerauLevenshtein[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_external.py
+)