summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gmail.com>2019-02-18 15:24:16 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-02-18 20:41:30 +0100
commitb6e4598c4d1fba5073698f2b50e10655a64eb5a1 (patch)
tree75cd96c23fa6d0c7a80f11d2d9495619e3f056af /dev-python/texttable
parentmedia-libs/lilv: keyword ~arm64 (diff)
downloadgentoo-b6e4598c4d1fba5073698f2b50e10655a64eb5a1.tar.gz
gentoo-b6e4598c4d1fba5073698f2b50e10655a64eb5a1.tar.bz2
gentoo-b6e4598c4d1fba5073698f2b50e10655a64eb5a1.zip
dev-python/texttable: bump to 1.6.1.
Package-Manager: Portage[mgorny]-2.3.51.1 Signed-off-by: Joonas Niilola <juippis@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11095 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/texttable')
-rw-r--r--dev-python/texttable/Manifest1
-rw-r--r--dev-python/texttable/texttable-1.6.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/texttable/Manifest b/dev-python/texttable/Manifest
index 1dbde3195a0b..cb388efceca8 100644
--- a/dev-python/texttable/Manifest
+++ b/dev-python/texttable/Manifest
@@ -1,2 +1,3 @@
DIST texttable-0.9.1.tar.gz 11074 BLAKE2B 465738a7b980f2a216d63b268044c1a1b8c0deb986fd398f0ba0ae30ab84020ac6f179b5314a2071592c38443f9cb86387b9ed573342533af9e825000472ebe5 SHA512 7ec37336ef4b253879d0232dcdb4500cad33ecce1067dd7ea26c221dc2c003ee56360bdbd1dd1e00133301c51c67fb2fe9b1703628804a65f2a6ab8a1e830e50
DIST texttable-1.6.0.tar.gz 10733 BLAKE2B 80a9b8a224ebaa37066df6a3aaccda6237224976076755b8f81a27eb20e3ef1c0811a529a877778b5ea7b1345ad16d510a7f3d9b6a1caadc582f34015faabb4e SHA512 df685004f24b8c1e7aa1bd6a44c658599805f1a0c6999a4a3e95ecf3a68499f515bea9cb5ccd54f5ee2563af15e9fcde2a7e1827934e4a1fc83c9ae2f5e88a52
+DIST texttable-1.6.1.tar.gz 11185 BLAKE2B d3fd85de8b6fa14ec6c520c0c0049ee043285fecaf7d31fbc1f361e0c9a27b66a75caf8aa0f85109523143f36ba2da47818ce91c4946c0b4d5391a0a4c5d9028 SHA512 72d4bb5c4f03b1f9dbfc4b1e375ad754e92610f71e65c7e9a0b7bdc88b3753254b143aa607570d49cfca56a3cf889a819e12ea184fdf34594f1f5d118de3c12c
diff --git a/dev-python/texttable/texttable-1.6.1.ebuild b/dev-python/texttable/texttable-1.6.1.ebuild
new file mode 100644
index 000000000000..7b84c8a238b9
--- /dev/null
+++ b/dev-python/texttable/texttable-1.6.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for creating simple ASCII tables"
+HOMEPAGE="https://github.com/foutaise/texttable https://pypi.org/project/texttable/"
+SRC_URI="https://github.com/foutaise/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cjk test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+ cjk? ( dev-python/cjkwrap[${PYTHON_USEDEP}] )
+ )
+"
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]
+ cjk? ( dev-python/cjkwrap[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest -vv tests.py || die
+}