summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-29 06:48:13 +0100
committerSam James <sam@gentoo.org>2023-08-29 06:54:22 +0100
commitfe04f24d7f2d11746412977289a2d47c9ac280d1 (patch)
tree47f5c9643bc1830b816273391fa66281b0b73052 /dev-python/thriftpy2
parentsys-devel/llvm-common: Remove old (diff)
downloadgentoo-fe04f24d7f2d11746412977289a2d47c9ac280d1.tar.gz
gentoo-fe04f24d7f2d11746412977289a2d47c9ac280d1.tar.bz2
gentoo-fe04f24d7f2d11746412977289a2d47c9ac280d1.zip
dev-python/thriftpy2: fix cython-3 compat
Closes: https://bugs.gentoo.org/898722 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/thriftpy2')
-rw-r--r--dev-python/thriftpy2/files/thriftpy2-0.4.16-cython3.patch25
-rw-r--r--dev-python/thriftpy2/thriftpy2-0.4.16-r1.ebuild52
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/thriftpy2/files/thriftpy2-0.4.16-cython3.patch b/dev-python/thriftpy2/files/thriftpy2-0.4.16-cython3.patch
new file mode 100644
index 000000000000..8e186d719d1e
--- /dev/null
+++ b/dev-python/thriftpy2/files/thriftpy2-0.4.16-cython3.patch
@@ -0,0 +1,25 @@
+https://bugs.gentoo.org/898722
+https://github.com/Thriftpy/thriftpy2/commit/202ed5ef7b91399b86f8b3b76108a14612b38dbc
+
+From 202ed5ef7b91399b86f8b3b76108a14612b38dbc Mon Sep 17 00:00:00 2001
+From: AN Long <aisk1988@gmail.com>
+Date: Mon, 7 Aug 2023 17:11:51 +0800
+Subject: [PATCH] fix: compatible with cython3
+
+---
+ thriftpy2/transport/cybase.pyx | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/thriftpy2/transport/cybase.pyx b/thriftpy2/transport/cybase.pyx
+index c05560f8..d0fc3696 100644
+--- a/thriftpy2/transport/cybase.pyx
++++ b/thriftpy2/transport/cybase.pyx
+@@ -87,7 +87,7 @@ cdef class TCyBuffer(object):
+ if min_size <= self.buf_size:
+ return 0
+
+- cdef int multiples = min_size / self.buf_size
++ cdef int multiples = min_size // self.buf_size
+ if min_size % self.buf_size != 0:
+ multiples += 1
+
diff --git a/dev-python/thriftpy2/thriftpy2-0.4.16-r1.ebuild b/dev-python/thriftpy2/thriftpy2-0.4.16-r1.ebuild
new file mode 100644
index 000000000000..c7e8bd364392
--- /dev/null
+++ b/dev-python/thriftpy2/thriftpy2-0.4.16-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python approach of Apache Thrift"
+HOMEPAGE="
+ https://github.com/Thriftpy/thriftpy2/
+ https://pypi.org/project/thriftpy2/
+"
+SRC_URI="
+ https://github.com/Thriftpy/thriftpy2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cython3.patch
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_exception
+ tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_result
+ )
+
+ cd tests || die
+ epytest
+}