summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-21 08:25:11 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-21 09:40:49 +0200
commit1fe87913446b9bfeceb603d3011acff9f2df375a (patch)
tree7b7b7d13437861084ea06b77f706aa6e7abc5f74 /dev-python/tifffile
parentdev-python/tifffile: Remove old (diff)
downloadgentoo-1fe87913446b9bfeceb603d3011acff9f2df375a.tar.gz
gentoo-1fe87913446b9bfeceb603d3011acff9f2df375a.tar.bz2
gentoo-1fe87913446b9bfeceb603d3011acff9f2df375a.zip
dev-python/tifffile: Bump to 2024.9.20
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest1
-rw-r--r--dev-python/tifffile/tifffile-2024.9.20.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index d8f9b18b74d6..9014f6e208a2 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1 +1,2 @@
DIST tifffile-2024.8.30.gh.tar.gz 353606 BLAKE2B 866248a948e141d7feb0770d51ec0cef5ba8e6474eb1238cde877b0e04525ac9126e4e0b11f1f64811c6a81a7084f6382a0f35f5e35e54862331f979ce5faf70 SHA512 f81e93c55cc982e12c9f0872b8099cb5e1dc6f4a3d18411a1d0f073080e20bf35a89d7115f4c8617f83c923e04c371a0db64d10b121a254db86b78c8a55d6d08
+DIST tifffile-2024.9.20.gh.tar.gz 355281 BLAKE2B 485418ce16bcc74c331b71a11ac4fdd82a3f67a0630bb9e70e8fc04cad1998ae46e13e5ba6c6ca3c7d7cee38396f199e5853681b968cdb515074110da706787d SHA512 f4840b40e59e66a6900b46576709c4910b20be0b820becc81b281540654b899e60a52bedf240a49c7f6140cbf91a268b9ba538fc3439715872f00e3603dffff2
diff --git a/dev-python/tifffile/tifffile-2024.9.20.ebuild b/dev-python/tifffile/tifffile-2024.9.20.ebuild
new file mode 100644
index 000000000000..a9bd677f4e53
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2024.9.20.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x SKIP_LARGE=1
+ local -x SKIP_HTTP=1
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}