summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-07 15:29:51 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-07 16:10:33 +0200
commit77bd14b6d0781d1e7b14b7c4ab9dc41972fa0756 (patch)
tree5986938f6bd797526f636d04e8c0d68a2ea5e847 /dev-python/time-machine
parentdev-python/yattag: Bump to 1.16.0 (diff)
downloadgentoo-77bd14b6d0781d1e7b14b7c4ab9dc41972fa0756.tar.gz
gentoo-77bd14b6d0781d1e7b14b7c4ab9dc41972fa0756.tar.bz2
gentoo-77bd14b6d0781d1e7b14b7c4ab9dc41972fa0756.zip
dev-python/time-machine: Bump to 2.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/time-machine')
-rw-r--r--dev-python/time-machine/Manifest1
-rw-r--r--dev-python/time-machine/time-machine-2.15.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/time-machine/Manifest b/dev-python/time-machine/Manifest
index 25d87015bdf6..776f95588e59 100644
--- a/dev-python/time-machine/Manifest
+++ b/dev-python/time-machine/Manifest
@@ -1,2 +1,3 @@
DIST time-machine-2.14.1.gh.tar.gz 29600 BLAKE2B b118e3a2f08f75cc6cd89181a9e533c89bc6e5312a520b2a854fb8aa7ac59f1570e48a85788261f781ef83f9864380318074724f6eadab9cda7a3374b2322e7d SHA512 42a127e2dc5a86e33896010e6d141fc9248fe685d3477ec71ec8a72315914cea99ae4a4d6623a59fd69505d935d2feadcfd831a7fff5617c3f98a93d48652ecf
DIST time-machine-2.14.2.gh.tar.gz 29671 BLAKE2B a53804ab324fcef3d5a387de6451ecd031310eefa17f6d2279fe70f0af3ff8f001ea581ac392c9e72f259dba49ae03eb82279804874a49f6131e5c6cf0131aa0 SHA512 b1996f762aabd161d7f66720265d520ff419a08525da603d805e95e5035cef4576e57d87b6c71a98dddc7cfb33d27e11f7b3d7999ca1be25b81ec0ab502f7012
+DIST time-machine-2.15.0.gh.tar.gz 29696 BLAKE2B c1008957e1206d4297ff63f1146f7411e96aae5805a7217af0989b7c77adfe8f447c1c0a36d8b488fd5b25370aebc92a511eeaad85005b5b0c7410480497e229 SHA512 3221a131ffe042f2e222950ca3241050e3275ac209c0df806da290b63c5fc43efbfb202ae030096c29c6390a6467bc05d476d4a3cef9465ea63473e50e3629c7
diff --git a/dev-python/time-machine/time-machine-2.15.0.ebuild b/dev-python/time-machine/time-machine-2.15.0.ebuild
new file mode 100644
index 000000000000..1087552cdae0
--- /dev/null
+++ b/dev-python/time-machine/time-machine-2.15.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Travel through time in your tests"
+HOMEPAGE="
+ https://github.com/adamchainz/time-machine/
+ https://pypi.org/project/time-machine/
+"
+SRC_URI="
+ https://github.com/adamchainz/time-machine/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest