summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-11 05:36:10 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-11 06:14:15 +0100
commitce52cc072ed845ca70844c897aa70605a15827e6 (patch)
tree5268676ce055f35532dd0dd2fdcef51f1bebcda4 /dev-python/toposort
parentdev-python/pyghmi: Bump to 1.5.56 (diff)
downloadgentoo-ce52cc072ed845ca70844c897aa70605a15827e6.tar.gz
gentoo-ce52cc072ed845ca70844c897aa70605a15827e6.tar.bz2
gentoo-ce52cc072ed845ca70844c897aa70605a15827e6.zip
dev-python/toposort: Bump to 1.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/toposort')
-rw-r--r--dev-python/toposort/Manifest1
-rw-r--r--dev-python/toposort/toposort-1.8.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/toposort/Manifest b/dev-python/toposort/Manifest
index 88d7234e8335..771cacee77bc 100644
--- a/dev-python/toposort/Manifest
+++ b/dev-python/toposort/Manifest
@@ -1 +1,2 @@
DIST toposort-1.7.tar.gz 10671 BLAKE2B 89da22e803c334cec77d5ac8ad6a9ab8013f7516555c2822bd6d511edf28230c85c2eaeabad3dc4a24a58ae3ce3850d407ad957d0e28491574557140a286843a SHA512 a585d1c103b2162fa3f37f6b0ef60a8709f08d9543d7fab619af3718bf9f752a293e50061d370fd08872b2d8a8db504cb9d9c1cce5446885b46fe8e833813833
+DIST toposort-1.8.tar.gz 10688 BLAKE2B 354070b8d723a5d75e1c4050b91268d8d747f1d345be58315914b8c3caf9ce0f975a64f281e336952f7e507269b14d4c1c6310b5c7702e0066b25b2f3caab1ed SHA512 f567e371d1524dc6c285a1a25780b92a8052f3c80b8207fbb8d7a5396fb7434ea503e3fac2755443ed52d9383185d2d0f89e18db011ba8b48f2cd013b552f29a
diff --git a/dev-python/toposort/toposort-1.8.ebuild b/dev-python/toposort/toposort-1.8.ebuild
new file mode 100644
index 000000000000..93680abc0927
--- /dev/null
+++ b/dev-python/toposort/toposort-1.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements a topological sort algorithm"
+HOMEPAGE="
+ https://gitlab.com/ericvsmith/toposort/
+ https://pypi.org/project/toposort/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" test/test_toposort.py -v || die "Tests failed with ${EPYTHON}"
+}