summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-03 20:52:53 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-03 20:55:52 +0200
commit5968bc7d12ea06a5a92982ddc8eb091f46bd3b84 (patch)
treed08d6e9969b194cbe37d323af564eaa1b4166522 /dev-python/transitions
parentdev-python/transitions: bump to version 0.8.2 (diff)
downloadgentoo-5968bc7d12ea06a5a92982ddc8eb091f46bd3b84.tar.gz
gentoo-5968bc7d12ea06a5a92982ddc8eb091f46bd3b84.tar.bz2
gentoo-5968bc7d12ea06a5a92982ddc8eb091f46bd3b84.zip
dev-python/transitions: fix tests
Added missing deps and changed tests to use correctly pytest. Bug: https://bugs.gentoo.org/733884 Bug: https://bugs.gentoo.org/732570 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python/transitions')
-rw-r--r--dev-python/transitions/transitions-0.7.1-r1.ebuild45
-rw-r--r--dev-python/transitions/transitions-0.8.1-r1.ebuild45
2 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/transitions/transitions-0.7.1-r1.ebuild b/dev-python/transitions/transitions-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..23b568a3c791
--- /dev/null
+++ b/dev-python/transitions/transitions-0.7.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight, object-oriented state machine implementation in Python"
+HOMEPAGE="https://github.com/pytransitions/transitions"
+SRC_URI="https://github.com/pytransitions/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/dill[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ use examples && dodoc examples/*.ipynb
+}
diff --git a/dev-python/transitions/transitions-0.8.1-r1.ebuild b/dev-python/transitions/transitions-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..9256f6b345ca
--- /dev/null
+++ b/dev-python/transitions/transitions-0.8.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight, object-oriented state machine implementation in Python"
+HOMEPAGE="https://github.com/pytransitions/transitions"
+SRC_URI="https://github.com/pytransitions/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/dill[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ use examples && dodoc examples/*.ipynb
+}