summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-02-04 14:10:44 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-02-04 20:25:32 +0100
commit6b8b11cbc6be477780fc962e640af0e111225563 (patch)
tree76244a9c7042029d5a14d5e0c9a4818a1a4e4f2a /dev-python/translate-toolkit/translate-toolkit-2.0.0.ebuild
parentwww-plugins/chrome-binary-plugins: drop libwidvinecdm.so (diff)
downloadgentoo-6b8b11cbc6be477780fc962e640af0e111225563.tar.gz
gentoo-6b8b11cbc6be477780fc962e640af0e111225563.tar.bz2
gentoo-6b8b11cbc6be477780fc962e640af0e111225563.zip
dev-python/translate-toolkit: 2.0.0 version bump
Gentoo-bug: 608108 Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-python/translate-toolkit/translate-toolkit-2.0.0.ebuild')
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-2.0.0.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/translate-toolkit/translate-toolkit-2.0.0.ebuild b/dev-python/translate-toolkit/translate-toolkit-2.0.0.ebuild
new file mode 100644
index 000000000000..327a54b47247
--- /dev/null
+++ b/dev-python/translate-toolkit/translate-toolkit-2.0.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/-toolkit}"
+MY_PV="${PV/_beta/b}"
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Toolkit to convert between many translation formats"
+HOMEPAGE="https://github.com/translate/translate"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc +html +ical +ini +subtitles +yaml"
+
+COMMON_DEPEND="
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+DEPEND="${COMMON_DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ !dev-python/pydiff
+ app-text/iso-codes
+ >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
+ dev-python/diff-match-patch[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.5[${PYTHON_USEDEP}]
+ >=dev-python/python-levenshtein-0.12.0[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
+ ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
+ ini? ( dev-python/iniparse[${PYTHON_USEDEP}] )
+ subtitles? ( $(python_gen_cond_dep 'media-video/gaupol[${PYTHON_USEDEP}]' 'python3*') )
+ yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
+"
+
+REQUIRED_USE="
+ subtitles? ( || ( $(python_gen_useflags 'python3*') ) )
+"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+python_prepare_all() {
+ # Prevent unwanted d'loading in doc build
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" \
+ -e "/html_theme/ s/sphinx-bootstrap/classic/" \
+ -i docs/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( "${S}"/docs/_build/html/. )
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ rm -Rf docs || die
+ if ! use html; then
+ rm "${ED%/}"/usr/bin/{html2po,po2html} || die
+ fi
+ if ! use ical; then
+ rm "${ED%/}"/usr/bin/{ical2po,po2ical} || die
+ fi
+ if ! use ini; then
+ rm "${ED%/}"/usr/bin/{ini2po,po2ini} || die
+ fi
+ if ! use subtitles; then
+ rm "${ED%/}"/usr/bin/{sub2po,po2sub} || die
+ fi
+}