summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-14 06:22:56 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-14 07:08:28 +0200
commit91ff006e67a80c5a958fb43b0a84839d1be351e4 (patch)
tree0191378ed532ac1ddc790bcaa4ffd8a0ecf6a92d /dev-python/trimesh
parentdev-python/absl-py: Bump to 1.3.0 (diff)
downloadgentoo-91ff006e67a80c5a958fb43b0a84839d1be351e4.tar.gz
gentoo-91ff006e67a80c5a958fb43b0a84839d1be351e4.tar.bz2
gentoo-91ff006e67a80c5a958fb43b0a84839d1be351e4.zip
dev-python/trimesh: Bump to 3.15.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest1
-rw-r--r--dev-python/trimesh/trimesh-3.15.5.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index d55c43f297ee..b82344224ce5 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -2,3 +2,4 @@ DIST trimesh-3.14.1.gh.tar.gz 11961899 BLAKE2B eab37c94da03cfdefa2f4bff78a1a1cdd
DIST trimesh-3.15.2.gh.tar.gz 11956076 BLAKE2B 4ec701056efd29eb24eaf4edc82d07af4b8e02713697f658ea86eaef6f94916d51c3b21873b3da720705f281054ab5564f4331dc3ee9614d37774bdc03dd1c77 SHA512 9ae3917f2485f5eba089fd04029187be356bbb032d8afa57801a5c19a897550a34bd6734848a47c937b42745fd4563a5a05352928f5e31a7146a3b002d6c765d
DIST trimesh-3.15.3.gh.tar.gz 11955970 BLAKE2B 050a1330ff0d3d308f3f54bee9080907b839e8cfcc9bdc831d3c5033225a9868aefe2ceb39313949288c779a1af577911a7e43fe2745f50c4983c178dcf02742 SHA512 e01192496af519be7f4d04b6268f82227a0d00c2feebf294572cdd6cce151d10d271cb8b8558c48200338d2f6ea4137fe75d92d115ea8b42f0117ad135566d05
DIST trimesh-3.15.4.gh.tar.gz 11956349 BLAKE2B 5d67b4e7ce0183fb9031c4cf032caf56e366b0ff05713a22d83258d13283b5bca5b08174044aa29af1d02112717c21be668315d99ea3ce203f318416b9eff583 SHA512 98e2711d46f8299132f0fd32b347393a4fc300f08c93f81e6e82b662bac57044678c425455549899ef839467d9a0dc249a4a03c14c816f0377545b74e6523e00
+DIST trimesh-3.15.5.gh.tar.gz 11956403 BLAKE2B 5e36a7fd57689f5151ee710a707bf44ff4c9538c3f541cd3d29bb08722b4bfeead7f138dab02a58a80d18b4831044d1ac674e3defd0e378420540976c422fc22 SHA512 4433480ff96be561d32412870c71420699713c53d34b2f84eabb1fa1eaa9e70d74940674e62a547c31e22dd941bb036179785a35ff2c8d27288300033497d5ac
diff --git a/dev-python/trimesh/trimesh-3.15.5.ebuild b/dev-python/trimesh/trimesh-3.15.5.ebuild
new file mode 100644
index 000000000000..11e1a73dfac5
--- /dev/null
+++ b/dev-python/trimesh/trimesh-3.15.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimsh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -n "$(makeopts_jobs)"
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}