summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-27 14:15:43 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-27 14:46:20 +0100
commit1249c1ff11b35bd003ce0c65ce7c3910c5aa1bfb (patch)
tree442820338beef66c5c499026f13cdf824e1a1f90 /dev-python/trio
parentdev-python/trio: Remove unused SSL test deps (diff)
downloadgentoo-1249c1ff11b35bd003ce0c65ce7c3910c5aa1bfb.tar.gz
gentoo-1249c1ff11b35bd003ce0c65ce7c3910c5aa1bfb.tar.bz2
gentoo-1249c1ff11b35bd003ce0c65ce7c3910c5aa1bfb.zip
dev-python/trio: Use EPYTEST_IGNORE for Internet tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/trio-0.19.0.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/dev-python/trio/trio-0.19.0.ebuild b/dev-python/trio/trio-0.19.0.ebuild
index 3a0aecc30f71..b02ca40ed6e5 100644
--- a/dev-python/trio/trio-0.19.0.ebuild
+++ b/dev-python/trio/trio-0.19.0.ebuild
@@ -52,17 +52,15 @@ EPYTEST_DESELECT=(
trio/tests/test_exports.py::test_static_tool_sees_all_symbols
)
+EPYTEST_IGNORE=(
+ # these tests require internet access
+ trio/tests/test_ssl.py
+ trio/tests/test_highlevel_ssl_helpers.py
+)
+
distutils_enable_tests --install pytest
distutils_enable_sphinx docs/source \
dev-python/immutables \
dev-python/sphinxcontrib-trio \
dev-python/sphinx_rtd_theme \
dev-python/towncrier
-
-python_prepare_all() {
- # these tests require internet access
- rm trio/tests/test_ssl.py || die
- rm trio/tests/test_highlevel_ssl_helpers.py || die
-
- distutils-r1_python_prepare_all
-}