summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-21 12:32:37 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-21 12:34:14 +0100
commitb5bd7552fb69e7a5eff2263b8a977657ccd3bc45 (patch)
tree96fd725ab14626d2331aa1760008c87127fb8981 /dev-python/twine
parentdev-python/six: Remove old (diff)
downloadgentoo-b5bd7552fb69e7a5eff2263b8a977657ccd3bc45.tar.gz
gentoo-b5bd7552fb69e7a5eff2263b8a977657ccd3bc45.tar.bz2
gentoo-b5bd7552fb69e7a5eff2263b8a977657ccd3bc45.zip
dev-python/twine: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/twine')
-rw-r--r--dev-python/twine/Manifest1
-rw-r--r--dev-python/twine/twine-5.1.1-r1.ebuild83
2 files changed, 0 insertions, 84 deletions
diff --git a/dev-python/twine/Manifest b/dev-python/twine/Manifest
index 837c2a59ec76..508da79d41f1 100644
--- a/dev-python/twine/Manifest
+++ b/dev-python/twine/Manifest
@@ -1,2 +1 @@
-DIST twine-5.1.1.gh.tar.gz 221931 BLAKE2B a95d50e52bde5db64c6ce5b57097188e9cb88763c91f337c3e552ca34bae34882d87bced4b0c55a292de185fce10384edf514b55373c4456ff252471076bcb28 SHA512 95f059235e32134a5320c0835befa2eed6eff35c56685afe4848224042c2e2af484db72f20fd0cfbe979cce8d495e8bb2d2ea38aca2c53ca7af8de378816bedf
DIST twine-6.0.1.gh.tar.gz 223827 BLAKE2B ab88eb21908954ee7c32744ae9f7ccd7d50cb2b5207917144ef559e142837c89625596dea2c1bb0be21858bb0967690df999bb8a123e01beb5637a025dc490f9 SHA512 4fa7727d0728da3e05eaca068bf1dd85656225dd61958666ec0747359ee6bd88b25fd443d6c77bd8db245e71418cf8e5b594a6559ac1ecaafe3c079ecaefadba
diff --git a/dev-python/twine/twine-5.1.1-r1.ebuild b/dev-python/twine/twine-5.1.1-r1.ebuild
deleted file mode 100644
index 0f45d4508bb3..000000000000
--- a/dev-python/twine/twine-5.1.1-r1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of utilities for publishing packages on PyPI"
-HOMEPAGE="
- https://twine.readthedocs.io/
- https://github.com/pypa/twine/
- https://pypi.org/project/twine/
-"
-SRC_URI="
- https://github.com/pypa/twine/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
- >=dev-python/importlib-metadata-3.6[${PYTHON_USEDEP}]
- >=dev-python/keyring-15.1[${PYTHON_USEDEP}]
- >=dev-python/pkginfo-1.8.1[${PYTHON_USEDEP}]
- >=dev-python/readme-renderer-35.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
- >=dev-python/requests-toolbelt-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/rfc3986-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/build[${PYTHON_USEDEP}]
- dev-python/jaraco-envs[${PYTHON_USEDEP}]
- dev-python/jaraco-functools[${PYTHON_USEDEP}]
- dev-python/munch[${PYTHON_USEDEP}]
- dev-python/portend[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pypiserver[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-
- # pytest-socket dep relevant only to test_integration, and upstream
- # disables it anyway
- sed -i -e '/--disable-socket/d' pytest.ini || die
- sed -i -e '/--cov/d' pytest.ini || die
- # unnecessary pin
- sed -i -e '/pkginfo </d' pyproject.toml || die
-
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-}
-
-python_test() {
- local EPYTEST_IGNORE=(
- # Internet
- tests/test_integration.py
- )
- local EPYTEST_DESELECT=(
- # Regression due to deps?
- tests/test_check.py::test_fails_rst_no_content
- # Avoid needing heavy virtualx
- tests/test_auth.py::test_warns_for_empty_password
- # https://github.com/pypa/twine/issues/1116
- 'tests/test_package.py::test_pkginfo_returns_no_metadata[unsupported Metadata-Version]'
- )
-
- local -x COLUMNS=80
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}