summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-01-27 17:57:37 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-01-27 17:57:37 +0200
commit77e83c646a626e079ccd19be0af7919f9e1b9c71 (patch)
treed01ab595b0b9e57adccebe87fd1ce0bbc856f13d /dev-python/txrequests
parentapp-containers/sen: EAPI=8, PEP517 (diff)
downloadgentoo-77e83c646a626e079ccd19be0af7919f9e1b9c71.tar.gz
gentoo-77e83c646a626e079ccd19be0af7919f9e1b9c71.tar.bz2
gentoo-77e83c646a626e079ccd19be0af7919f9e1b9c71.zip
dev-python/txrequests: Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/txrequests')
-rw-r--r--dev-python/txrequests/txrequests-0.9.6-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/txrequests/txrequests-0.9.6-r1.ebuild b/dev-python/txrequests/txrequests-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..702041359e4e
--- /dev/null
+++ b/dev-python/txrequests/txrequests-0.9.6-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Asynchronous Python HTTP for Humans"
+HOMEPAGE="https://github.com/tardyp/txrequests"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/requests-1.2.0[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( ${RDEPEND} )"
+
+python_test() {
+ "${EPYTHON}" -m twisted.trial txrequests || die "Tests failed with ${EPYTHON}"
+}