summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-23 20:59:25 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-23 21:07:55 +0200
commitf4f568d3a786c9e0a47ae3cd6a8f371ed61f4318 (patch)
tree97e947856f7b1d057cf08f52d4fa235c26a4b0d5 /dev-python/uritemplate
parentdev-python/zope-component: Bump to 5.0.1 (diff)
downloadgentoo-f4f568d3a786c9e0a47ae3cd6a8f371ed61f4318.tar.gz
gentoo-f4f568d3a786c9e0a47ae3cd6a8f371ed61f4318.tar.bz2
gentoo-f4f568d3a786c9e0a47ae3cd6a8f371ed61f4318.zip
dev-python/uritemplate: Bump to 4.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uritemplate')
-rw-r--r--dev-python/uritemplate/Manifest1
-rw-r--r--dev-python/uritemplate/metadata.xml1
-rw-r--r--dev-python/uritemplate/uritemplate-4.1.1.ebuild23
3 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/uritemplate/Manifest b/dev-python/uritemplate/Manifest
index 9d0f75f84da6..21e82e3c839b 100644
--- a/dev-python/uritemplate/Manifest
+++ b/dev-python/uritemplate/Manifest
@@ -1 +1,2 @@
DIST uritemplate-4.1.0.tar.gz 273924 BLAKE2B b21115c6db8f94c635dda1033b4650dd7d2d54b6f52f51bff31ae8cf89e0b3dbcfc1bd029eadc68f5f94eecbd167eabc652c24be6f0bb807beecb5f254520626 SHA512 e62812a4e9ff315a1b06ba9e88f3dd47aea8353cae4ead9ce7bf59b65c83cd6ae7c973cb29b8ddc25266c264f229df8f2d9e982ab489f2f37a5dbd460b87a5e0
+DIST uritemplate-4.1.1.tar.gz 273898 BLAKE2B 08a9179da7ccdb8b6d1a85ccf34f44f8282e6b5a00ddea541364272816588c238f4f8f960a197a7e8074607bcb8d1b52226740bddf0b92fb3751cb2d4b8fad51 SHA512 7682c7dcd9c8d4428b047e3adbc283b78f755face4d8dd1b0cd11df9583bd0435543640ba79229d436aeecad2b5b29684befdccc84ba71f72769ee130cb6576a
diff --git a/dev-python/uritemplate/metadata.xml b/dev-python/uritemplate/metadata.xml
index 7f6fc597dc21..b3847947546a 100644
--- a/dev-python/uritemplate/metadata.xml
+++ b/dev-python/uritemplate/metadata.xml
@@ -6,6 +6,7 @@
<name>Python</name>
</maintainer>
<upstream>
+ <remote-id type="github">python-hyper/uritemplate</remote-id>
<remote-id type="pypi">uritemplate</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/uritemplate/uritemplate-4.1.1.ebuild b/dev-python/uritemplate/uritemplate-4.1.1.ebuild
new file mode 100644
index 000000000000..03074a16d07e
--- /dev/null
+++ b/dev-python/uritemplate/uritemplate-4.1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of RFC6570, URI Template"
+HOMEPAGE="
+ https://uritemplate.readthedocs.io/en/latest/
+ https://pypi.org/project/uritemplate/
+ https://github.com/python-hyper/uritemplate/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest