summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-14 22:51:58 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-14 23:00:12 +0200
commit1db32f579e461bfb97903983bf41ae8bd8f47649 (patch)
treef828916c0092038144a0854ce5f42f65d9c1d4d5 /dev-python/uvicorn
parentdev-python/cppy: add 1.2.0 (diff)
downloadgentoo-1db32f579e461bfb97903983bf41ae8bd8f47649.tar.gz
gentoo-1db32f579e461bfb97903983bf41ae8bd8f47649.tar.bz2
gentoo-1db32f579e461bfb97903983bf41ae8bd8f47649.zip
dev-python/uvicorn: add 0.17.6
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/uvicorn')
-rw-r--r--dev-python/uvicorn/Manifest1
-rw-r--r--dev-python/uvicorn/uvicorn-0.17.6.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/uvicorn/Manifest b/dev-python/uvicorn/Manifest
index fa147619b83c..80193973cf5c 100644
--- a/dev-python/uvicorn/Manifest
+++ b/dev-python/uvicorn/Manifest
@@ -1,3 +1,4 @@
DIST uvicorn-0.17.3.tar.gz 706936 BLAKE2B f96f1707fc966f2972392a413517ba4f3f65097c83134bd648a759ef65496ffa166507d64a2c51d5c301adab4203e0766ab2b359d1182dceeb31dd70e6bbf8e3 SHA512 d2a35a69420b2715c2688be341860958b8697c1565d5b2665d4b9c6fa7bf72060e61f72bfd99fb7c346df48f4a962e3c7a7118dd1d0782bc35ac0fcc57cb4e1d
DIST uvicorn-0.17.4.tar.gz 706950 BLAKE2B 51d30a97f70984929bc4d4eb3934a16514307ff3e504f86813d0b5ea81467cc5fcc06da6aaa298f0319b2ccddf88b02ee4006ba9f1d573da50365cc4455f5da3 SHA512 4e61d712551ee6e6471f88f511e31b5543ef16d8ebe960447f5de6d02753bdbc38fd5fbae0d736b54b01a61d8519ef3891db2bbc1c7440806650b92a765d1d23
DIST uvicorn-0.17.5.tar.gz 707840 BLAKE2B 70a5aa4c084f63231b2c4f11c9a4add6a84362789243fe59b4c954665b67f859dcd92076454cac7b960d30c878bccb52e6da5232e052d70ca0a71f4035804b96 SHA512 b73c99d03957bf5f37957386da77cad68e0c9603fb0bfe48ab81f1066953ca01bc75b2eb458a20a587df4f2e1f591fe1c56f26d8df84070c833ccbb912d55ca2
+DIST uvicorn-0.17.6.tar.gz 708048 BLAKE2B 83b06907c8109b38e13930d8b73584682fa4e34fe7e51fe14b6ca1ddc7ef8122d950a09e31cb364a02f5f12eead5d0522b41cbf428509c6900604d4e2776dfb2 SHA512 d5c5223759d59648f279e22f7e6af728fe8117ed75488d125c1db3e5e9d385a50d574cff72ac46db4eb0a78d0e4f690096cfe78c774674dfba61860e55b7494e
diff --git a/dev-python/uvicorn/uvicorn-0.17.6.ebuild b/dev-python/uvicorn/uvicorn-0.17.6.ebuild
new file mode 100644
index 000000000000..7539908c79ed
--- /dev/null
+++ b/dev-python/uvicorn/uvicorn-0.17.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lightning-fast ASGI server implementation"
+HOMEPAGE="https://www.uvicorn.org/"
+SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/asgiref-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/h11-0.8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ >=dev-python/websockets-10.0[${PYTHON_USEDEP}]
+ dev-python/watchgod[${PYTHON_USEDEP}]
+ dev-python/wsproto[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # too long path for unix socket
+ tests/test_config.py::test_bind_unix_socket_works_with_reload_or_workers
+ # need unpackaged httptools
+ "tests/middleware/test_logging.py::test_trace_logging_on_http_protocol[httptools]"
+ tests/protocols/test_http.py::test_fragmentation
+)