summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-21 10:43:48 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-21 11:09:37 +0200
commitb6b84926d7974b3ef5bc48ad91b18a9472e89e11 (patch)
tree12dd24057f2038e705452670e87ec23c7e40bdd7 /dev-python/virtualenv-clone
parentnet-misc/electrum: Make qdarkstyle dep optional (diff)
downloadgentoo-b6b84926d7974b3ef5bc48ad91b18a9472e89e11.tar.gz
gentoo-b6b84926d7974b3ef5bc48ad91b18a9472e89e11.tar.bz2
gentoo-b6b84926d7974b3ef5bc48ad91b18a9472e89e11.zip
dev-python/virtualenv-clone: Bump to 0.5.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/virtualenv-clone')
-rw-r--r--dev-python/virtualenv-clone/Manifest1
-rw-r--r--dev-python/virtualenv-clone/virtualenv-clone-0.5.7.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/virtualenv-clone/Manifest b/dev-python/virtualenv-clone/Manifest
index 25dc92f02efe..2dd7b31a38df 100644
--- a/dev-python/virtualenv-clone/Manifest
+++ b/dev-python/virtualenv-clone/Manifest
@@ -1 +1,2 @@
DIST virtualenv-clone-0.5.6.gh.tar.gz 8723 BLAKE2B 2bac625f85a26ac2224fb982230fdf592963ac462d6d86c59100bf960fc37dd4ae7ae9da0e6234e1b2952d77ce55e0a0c60c06c7db4868709638f21479e8150b SHA512 5788a3d2994b3cbf4ec4668e2d0597e7a033a5eb13465b3964aeb2a38c5798a879e818a88a9cfa37b87a9aae534416c157cd82959af556b6ec94ffbc755ba844
+DIST virtualenv-clone-0.5.7.gh.tar.gz 8749 BLAKE2B 584f67c5a1921667ff2daf3b632ca6661d60ace166c6d05e22783a37c4387a92ec1a97990eb7a0c1a687d3e14d258df54b8b81c560458e33c31657c2c378382a SHA512 a71cc1e02ac70fb41945a505297ae894a0bd17e397f90b7cc9ddff599b2f649ca24d3e767a2672e8c27c387e5a235ec6bcbbfcdeb9a0c6e6d4600cf7f4149f4a
diff --git a/dev-python/virtualenv-clone/virtualenv-clone-0.5.7.ebuild b/dev-python/virtualenv-clone/virtualenv-clone-0.5.7.ebuild
new file mode 100644
index 000000000000..d7c7d6520d7c
--- /dev/null
+++ b/dev-python/virtualenv-clone/virtualenv-clone-0.5.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A script for cloning a non-relocatable virtualenv"
+HOMEPAGE="
+ https://github.com/edwardgeorge/virtualenv-clone/
+ https://pypi.org/project/virtualenv-clone/
+"
+SRC_URI="
+ https://github.com/edwardgeorge/virtualenv-clone/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest