summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-01 12:38:09 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-01 12:55:34 +0200
commit3c3a5165dbcf6fc000a8616a8394ed3b165eb93a (patch)
treefaf1a23c8dffe29480cd1998d9e1c05fc112d524 /dev-python/vncdotool
parentdev-python/pyvirtualdisplay: enable py3.11 (diff)
downloadgentoo-3c3a5165dbcf6fc000a8616a8394ed3b165eb93a.tar.gz
gentoo-3c3a5165dbcf6fc000a8616a8394ed3b165eb93a.tar.bz2
gentoo-3c3a5165dbcf6fc000a8616a8394ed3b165eb93a.zip
dev-python/vncdotool: enable py3.11, pep517
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/vncdotool')
-rw-r--r--dev-python/vncdotool/vncdotool-0.13.0-r1.ebuild39
-rw-r--r--dev-python/vncdotool/vncdotool-1.0.0-r1.ebuild39
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/vncdotool/vncdotool-0.13.0-r1.ebuild b/dev-python/vncdotool/vncdotool-0.13.0-r1.ebuild
new file mode 100644
index 000000000000..ffc8761dd794
--- /dev/null
+++ b/dev-python/vncdotool/vncdotool-0.13.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Command line VNC client"
+HOMEPAGE="https://github.com/sibson/vncdotool"
+SRC_URI="https://github.com/sibson/vncdotool/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# A lot of errors such as the following appear
+# pexpect.exceptions.ExceptionPexpect: The command was not found or was not executable: vncev.
+# to install those, a manual compile and install of examples from net-libs/libvncserver is needed
+RESTRICT="test"
+
+BDEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ dev-python/ptyprocess[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+)"
+RDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
diff --git a/dev-python/vncdotool/vncdotool-1.0.0-r1.ebuild b/dev-python/vncdotool/vncdotool-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..ffc8761dd794
--- /dev/null
+++ b/dev-python/vncdotool/vncdotool-1.0.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Command line VNC client"
+HOMEPAGE="https://github.com/sibson/vncdotool"
+SRC_URI="https://github.com/sibson/vncdotool/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# A lot of errors such as the following appear
+# pexpect.exceptions.ExceptionPexpect: The command was not found or was not executable: vncev.
+# to install those, a manual compile and install of examples from net-libs/libvncserver is needed
+RESTRICT="test"
+
+BDEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ dev-python/ptyprocess[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+)"
+RDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs