summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-07-09 10:44:16 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-07-09 11:00:32 +0200
commit4a2afc30c76464e932066821e8c49da263a802de (patch)
tree85f4764792ac475d965d8c8f373e9d81df3fbe84 /dev-python/wand
parentdev-python/retry-decorator: x86 stable wrt bug #731560 (diff)
downloadgentoo-4a2afc30c76464e932066821e8c49da263a802de.tar.gz
gentoo-4a2afc30c76464e932066821e8c49da263a802de.tar.bz2
gentoo-4a2afc30c76464e932066821e8c49da263a802de.zip
dev-python/wand: bump to 0.6.2, add Python 3.9 support
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/wand')
-rw-r--r--dev-python/wand/Manifest1
-rw-r--r--dev-python/wand/wand-0.6.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/wand/Manifest b/dev-python/wand/Manifest
index bfe67765c0e5..1b86d1b913f4 100644
--- a/dev-python/wand/Manifest
+++ b/dev-python/wand/Manifest
@@ -1 +1,2 @@
DIST Wand-0.6.1.tar.gz 10501178 BLAKE2B 76eb22363a20bc93fafae334a65917310cae82b0613b4b8b1eb749ef453268eb4413734ece7a39448d25782ce2ee8c63e71f9571707ec764851d82dbe5a6a6e4 SHA512 3edc4030130c1d03547d933f05eca4e9c9d10bdd527b1e41657a6b3f81d433da63fbbaddf63c726417f90335ac475508f1a467ee5e368eecb5cf9e94e79da9bf
+DIST Wand-0.6.2.tar.gz 10503865 BLAKE2B ad488a2d3d6b5801b20ca3caab884069cd5fb6913e04fb719885abdd49578f77cfc4b47a33235f4833463d75c01ad80e06c0687badb9c981a16c9c358c815032 SHA512 906490a0a75a4fc315b592fec12dea21cd40102c461381a79d5215c70ab6fb9c8a1e888fc478ea2ad006db6549dfdd2b7b1e01879cc2aba34dcc0cdd6ae2d128
diff --git a/dev-python/wand/wand-0.6.2.ebuild b/dev-python/wand/wand-0.6.2.ebuild
new file mode 100644
index 000000000000..094165125f7a
--- /dev/null
+++ b/dev-python/wand/wand-0.6.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
+
+inherit distutils-r1
+
+MY_P="${PN^}-${PV}"
+DESCRIPTION="Ctypes-based simple ImageMagick binding for Python"
+HOMEPAGE="http://wand-py.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="media-gfx/imagemagick"
+BDEPEND="
+ test? (
+ media-gfx/imagemagick[fftw,jpeg,png,truetype,xml]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ # PDF support is blocked by the default ImageMagick security policy
+ pytest -vv --skip-pdf || die "Tests fail with ${EPYTHON}"
+}