summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-05 05:49:07 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-05 05:49:07 +0100
commit5bdfb214d5b0ceca6f0ed4aedf9f781b085751c9 (patch)
tree23d2fdb390e437f64a800bb42941a48f7858a881 /dev-python/wrapt
parentdev-python/zeroconf: Bump to 0.120.0 (diff)
downloadgentoo-5bdfb214d5b0ceca6f0ed4aedf9f781b085751c9.tar.gz
gentoo-5bdfb214d5b0ceca6f0ed4aedf9f781b085751c9.tar.bz2
gentoo-5bdfb214d5b0ceca6f0ed4aedf9f781b085751c9.zip
dev-python/wrapt: Fix test failures on pypy3
Closes: https://bugs.gentoo.org/910536 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wrapt')
-rw-r--r--dev-python/wrapt/wrapt-1.15.0.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/wrapt/wrapt-1.15.0.ebuild b/dev-python/wrapt/wrapt-1.15.0.ebuild
index 9e33fe5a5171..bd4f60798893 100644
--- a/dev-python/wrapt/wrapt-1.15.0.ebuild
+++ b/dev-python/wrapt/wrapt-1.15.0.ebuild
@@ -26,6 +26,13 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv
distutils_enable_tests pytest
distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+src_prepare() {
+ # pypy3.9+ change, upstream commented this out
+ # in 59680c8bb998defa3be522fef6e49fd276bebe58
+ sed -i -e 's:if is_pypy:if False:' tests/test_object_proxy.py || die
+ distutils-r1_src_prepare
+}
+
python_compile() {
local -x WRAPT_INSTALL_EXTENSIONS=true
distutils-r1_python_compile