summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-26 19:57:43 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-26 23:24:08 -0500
commit9357af144561302d90c3bcf6fedd8f565377ad2f (patch)
tree339fefda7f156f02bac2b5fd9675ffa3d780baf6 /dev-python/wrapt
parentdev-python/stevedore: 1.25.0 bup (diff)
downloadgentoo-9357af144561302d90c3bcf6fedd8f565377ad2f.tar.gz
gentoo-9357af144561302d90c3bcf6fedd8f565377ad2f.tar.bz2
gentoo-9357af144561302d90c3bcf6fedd8f565377ad2f.zip
dev-python/wrapt: 1.10.10 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/wrapt')
-rw-r--r--dev-python/wrapt/Manifest1
-rw-r--r--dev-python/wrapt/wrapt-1.10.10.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/wrapt/Manifest b/dev-python/wrapt/Manifest
index 405577f400cc..6d4eeac2ca91 100644
--- a/dev-python/wrapt/Manifest
+++ b/dev-python/wrapt/Manifest
@@ -1,2 +1,3 @@
+DIST wrapt-1.10.10.tar.gz 122052 SHA256 ded853e421bbc7bb668b085391f2e2be9bd83f8e3565f8efddc937284446e3aa SHA512 e18283cac7bbb137f43fa8c2839fff14072db1fdae57da2b393a5db4007656706838b64bc6785cea25602205b595fc4e7fe033e580d2fb484fd8c77351e046d1 WHIRLPOOL e00854862bc0f0b8bd558642de3ffb99540166b6e888df7159185f1fe3d962e34cd5f88d483f245eb9b013c7d0120d4b9950cce0630a8dec08704d9ceb168b21
DIST wrapt-1.10.5.tar.gz 119157 SHA256 4fd82193b23f60e1a39f3e10c81143c1e29e26cd5fc9afe1a7dc0f5e4b4a67d7 SHA512 450b32eea67774081d23c0e020ed7eea3c8ac458925a16cd606a4f95ee5b7631bda5ff00ceb914e9ccc28a5e0a7302534b6711bb23d637c77327a8a9d228cb55 WHIRLPOOL 7cfa9477f525e60f16a7b1689ba43b327192837bea34e96977442b9cd143a63fafdfa7d0b3895c93052b0e6f426e76fa439b155ee4e481dd5e922c529676691c
DIST wrapt-1.10.8.tar.gz 120359 SHA256 096b47f44e3197934ccc335c53d2d21bf6ed9fd941b294726e26a1fd18fd4541 SHA512 2a37584b3c3a33a2d39d5cbe9f7e61a50131db55ffd5be7902b5ee84c347d8ff4d6094e5639d2f854fab274b2517a0e47420da9f543f11cf92973acd6d15d42e WHIRLPOOL 5f27b048b9f06c03c3e3acdd9c3a64308958585deb7e314c80158910cfc1eac154540a0e4a3c838718456d5ed38751d85f49645e634a7d2734cad916547a5bc7
diff --git a/dev-python/wrapt/wrapt-1.10.10.ebuild b/dev-python/wrapt/wrapt-1.10.10.ebuild
new file mode 100644
index 000000000000..5ff5ec966398
--- /dev/null
+++ b/dev-python/wrapt/wrapt-1.10.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Module for decorators, wrappers and monkey patching"
+HOMEPAGE="https://github.com/GrahamDumpleton/wrapt"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="doc test"
+
+DEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_compile() {
+ local WRAPT_EXTENSIONS=true
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ py.test -vv || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}