summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/wstools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/wstools')
-rw-r--r--dev-python/wstools/Manifest1
-rw-r--r--dev-python/wstools/metadata.xml9
-rw-r--r--dev-python/wstools/wstools-0.4.3.ebuild22
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/wstools/Manifest b/dev-python/wstools/Manifest
new file mode 100644
index 000000000000..31db4bd0c008
--- /dev/null
+++ b/dev-python/wstools/Manifest
@@ -0,0 +1 @@
+DIST wstools-0.4.3.tar.gz 148878 SHA256 578b53e98bc8dadf5a55dfd1f559fd9b37a594609f1883f23e8646d2d30336f8 SHA512 e735e2ae63aa410a56c79bef0bec7196393bb8f52d8521001d298b6290a75662f7262b6cd3c3238eeaf33263036cc6dabf8435ebd2fd1c98481cea524d0382ed WHIRLPOOL fa5ca24db23d99337cb08f3317327f6076f230c787477275e54d2322931d4e86831357043df6e8c12f3a62bac95eda13f614120588e9d3265ba40251c68b2881
diff --git a/dev-python/wstools/metadata.xml b/dev-python/wstools/metadata.xml
new file mode 100644
index 000000000000..34ca344eaee0
--- /dev/null
+++ b/dev-python/wstools/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">wstools</remote-id>
+ <remote-id type="github">kiorky/wstools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/wstools/wstools-0.4.3.ebuild b/dev-python/wstools/wstools-0.4.3.ebuild
new file mode 100644
index 000000000000..275085e514e2
--- /dev/null
+++ b/dev-python/wstools/wstools-0.4.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="WSDL parsing services package for Web Services for Python"
+HOMEPAGE="https://github.com/kiorky/wstools http://pypi.python.org/pypi/wstools"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"