summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-23 16:41:51 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-23 18:14:21 +0100
commit3bd56243fdf9883b3078f5d7191c8382d2003034 (patch)
treef54cbaaee8d98191fd8e24d83023997ce8a39c1e /dev-python/xarray/xarray-2023.3.0.ebuild
parentsys-fs/multipath-tools: prevent Makefile.inc from overriding CFLAGS (diff)
downloadgentoo-3bd56243fdf9883b3078f5d7191c8382d2003034.tar.gz
gentoo-3bd56243fdf9883b3078f5d7191c8382d2003034.tar.bz2
gentoo-3bd56243fdf9883b3078f5d7191c8382d2003034.zip
dev-python/xarray: Bump to 2023.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xarray/xarray-2023.3.0.ebuild')
-rw-r--r--dev-python/xarray/xarray-2023.3.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/xarray/xarray-2023.3.0.ebuild b/dev-python/xarray/xarray-2023.3.0.ebuild
new file mode 100644
index 000000000000..cc0d2354ba87
--- /dev/null
+++ b/dev-python/xarray/xarray-2023.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="
+ https://xarray.pydata.org/
+ https://github.com/pydata/xarray/
+ https://pypi.org/project/xarray/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ <dev-python/pandas-2[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.4[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+"
+# note: most of the test dependencies are optional
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+)