summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-16 10:26:40 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-16 10:54:39 +0100
commit26d89df7c75f0728eef50150bcb452dfcfd28782 (patch)
treeec81305c7db19bdfed05d5760d8e4ef9bed3e7f9 /dev-python/xarray
parentdev-python/flask-security: Bump to 4.1.3 (diff)
downloadgentoo-26d89df7c75f0728eef50150bcb452dfcfd28782.tar.gz
gentoo-26d89df7c75f0728eef50150bcb452dfcfd28782.tar.bz2
gentoo-26d89df7c75f0728eef50150bcb452dfcfd28782.zip
dev-python/xarray: Bump to 2022.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/Manifest1
-rw-r--r--dev-python/xarray/xarray-2022.3.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index db23a40b8926..8c9ff6d15b8e 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1,3 +1,4 @@
DIST xarray-0.20.2.tar.gz 2906021 BLAKE2B 08ed46a27ce66ec1677e63000d74ecc4a01defa81b8ae1ec24595ff330713bf3e5585adce541e5e6769a74d64a4f5eb9d9aad27450e8088973681d0d60d00f83 SHA512 cd292af68ffd8016e01021e30a2ea83dd36e2f79bd9c3d8e7d83adc5a98a95615091d0102a19a0e3337ae334a701f575a142f476d1465804c8d5fe259ca35f1a
DIST xarray-0.21.0.tar.gz 2937088 BLAKE2B b40d57cbb018e563b92afef1e5208bb597bf8ae892b154f49e90079977c05ab955ba07f136fcf3f456efa8deb70ffd2590dd2d2429b6114a418882b8d96b535f SHA512 85461b86ced78ad5cfd1ace122f1ab89f779a8c0c7e8d0f06233b4654c5f6bcb081eeddc91e5df1c8c40c344d2477f2f18799858e23294c0929e8e59445508b0
DIST xarray-0.21.1.tar.gz 2936861 BLAKE2B 4d419185a6c49f8054f43748fd7a0ba9694aa9e7377e371705dd6eceea84f5d611d445a7548a79133f8db4c65729c9b5f694ab586d5e2f55640a6369483e3df4 SHA512 be5d925971557f492c8ca7e90eb678a0f98cf0a670eaa8a8564bd160a02fcd8a22362a8691c5447a9baaa67b464257f2ab6954747296839b304f3e25cf13487a
+DIST xarray-2022.3.0.tar.gz 2943007 BLAKE2B 4c323573835c00275b9c293157c78e42d14f2736c07dc06c61643052992b9c75d624cdf9a93487094fbffd9577662388807b661d388032add3b2e2ca3a63b812 SHA512 c088b985a852c57dcef14d8a5107987c0c33f17bde1d9d639d30ac826d906639ce0ee4fe8345c65a5479b944057af045fe50c2d2ea932356aceb0718f55cd24a
diff --git a/dev-python/xarray/xarray-2022.3.0.ebuild b/dev-python/xarray/xarray-2022.3.0.ebuild
new file mode 100644
index 000000000000..ab14769c7814
--- /dev/null
+++ b/dev-python/xarray/xarray-2022.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="https://xarray.pydata.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.18[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]"
+# note: most of test dependencies are optional
+BDEPEND="
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.19.0-riscv_tests_datetime.patch
+)
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+)