summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-21 18:26:09 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-21 20:04:59 +0100
commitfbdb5d52e79ff1b12902118cb2f5a961e5c109e3 (patch)
tree62cbd9a99f83b59deabdb30f671603ccf3074ee5 /dev-python/yarl
parentdev-python/expandvars: New package, v0.11.0 (diff)
downloadgentoo-fbdb5d52e79ff1b12902118cb2f5a961e5c109e3.tar.gz
gentoo-fbdb5d52e79ff1b12902118cb2f5a961e5c109e3.tar.bz2
gentoo-fbdb5d52e79ff1b12902118cb2f5a961e5c109e3.zip
dev-python/yarl: Bump to 1.9.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/yarl')
-rw-r--r--dev-python/yarl/Manifest1
-rw-r--r--dev-python/yarl/yarl-1.9.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/yarl/Manifest b/dev-python/yarl/Manifest
index 769dea29903b..0b2854048acd 100644
--- a/dev-python/yarl/Manifest
+++ b/dev-python/yarl/Manifest
@@ -1 +1,2 @@
DIST yarl-1.9.2.tar.gz 184673 BLAKE2B bb94131059d0cfaf88f04d62a44181245ebcb660cb44904f0b7e8d497905a16d0026aeff454b8179fab5342c6bf9c8d6aadade0d9f7c70321c71bbcc3998e9a3 SHA512 ffbb6df94220bb1561333f1ad69a70334328e2273ec5e91c2741f6fd5ca2f6dd38d5b5f617728797fce490accc2394a406a5f9b5b665af4746746229af0d7c5f
+DIST yarl-1.9.3.tar.gz 135606 BLAKE2B f73b41227c08c791442c4c96ec961bcdbc8078f72082a842b6537a28b212c8612d700f2245e8c431008b652afd59a08be36137e92ebb15f1ea2c733bfc00dd4f SHA512 44dcc51c0b01eda024d9e6a236b95999a6be5989958362060b6b21c3d98fcb862824f7ec1897ac8c164ad2cb9362a2df4d40dcc980f57eaeefb0eddfc19b4741
diff --git a/dev-python/yarl/yarl-1.9.3.ebuild b/dev-python/yarl/yarl-1.9.3.ebuild
new file mode 100644
index 000000000000..d53ea83a040d
--- /dev/null
+++ b/dev-python/yarl/yarl-1.9.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Yet another URL library"
+HOMEPAGE="
+ https://github.com/aio-libs/yarl/
+ https://pypi.org/project/yarl/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/expandvars[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd tests || die
+ epytest --override-ini=addopts=
+}