summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-11 08:28:42 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-11 08:40:43 +0200
commitc0e5ba211fb2a7ff365366bb636fc726b01cee23 (patch)
tree1c84220ce625e1593633677a2912eaae46b51aa8 /dev-python/zope-exceptions/zope-exceptions-4.6.ebuild
parentapp-editors/vscodium: add 1.73.1.22314 (diff)
downloadgentoo-c0e5ba211fb2a7ff365366bb636fc726b01cee23.tar.gz
gentoo-c0e5ba211fb2a7ff365366bb636fc726b01cee23.tar.bz2
gentoo-c0e5ba211fb2a7ff365366bb636fc726b01cee23.zip
dev-python/zope-exceptions: add 4.6
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/zope-exceptions/zope-exceptions-4.6.ebuild')
-rw-r--r--dev-python/zope-exceptions/zope-exceptions-4.6.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/zope-exceptions/zope-exceptions-4.6.ebuild b/dev-python/zope-exceptions/zope-exceptions-4.6.ebuild
new file mode 100644
index 000000000000..89ee54d44763
--- /dev/null
+++ b/dev-python/zope-exceptions/zope-exceptions-4.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="General purpose exceptions for Zope packages"
+HOMEPAGE="
+ https://pypi.org/project/zope.exceptions/
+ https://github.com/zopefoundation/zope.exceptions/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ !dev-python/namespace-zope
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ distutils_write_namespace zope
+ eunittest
+}