summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-04 14:24:11 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-04 15:12:08 +0100
commit06b61a80ff861d11c603f15255989b4a63be19aa (patch)
tree3c88aaa5d2751b8bada3bf9aad50673dd76cb756 /dev-python
parentdev-python/simplejson: Bump to 3.18.1 (diff)
downloadgentoo-06b61a80ff861d11c603f15255989b4a63be19aa.tar.gz
gentoo-06b61a80ff861d11c603f15255989b4a63be19aa.tar.bz2
gentoo-06b61a80ff861d11c603f15255989b4a63be19aa.zip
dev-python/termcolor: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/termcolor/Manifest1
-rw-r--r--dev-python/termcolor/termcolor-2.2.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/termcolor/Manifest b/dev-python/termcolor/Manifest
index ad4c76af4eea..51d41b62b982 100644
--- a/dev-python/termcolor/Manifest
+++ b/dev-python/termcolor/Manifest
@@ -1 +1,2 @@
DIST python-termcolor-2.1.1.tar.gz 10831 BLAKE2B 0c5537f81234411ddb117266e45ac7ec8ea0af0f62e08883f4893aec21d83d03534200d1ad1633bed4c57cfd7a83305aaff5af7b0574d948854b7762c9e631f4 SHA512 f652d8ce07e192820c57d62fe76495e81e859a709e61b8a1418985da51a92ce8b71865b362d10331d40a914497fa2bf81e95c924c88ae281663a430ef065ca18
+DIST python-termcolor-2.2.0.tar.gz 11340 BLAKE2B c1a7119bf4b6a137784e1b395d65ce2222e78c3747d1198b0c3407a15b02aa2f0343a12ac067696f19e94b4add0f8968164223f77cc79ffb703601003b8ce8fd SHA512 24a686c6589a56d2ae9ef9a974dc2308d23e9dcbc586df2c2e6ce938f4a6d85bcd20e4ecafcdee8b5b859917defd2965804e10ef761ce7929dc44826f0fca402
diff --git a/dev-python/termcolor/termcolor-2.2.0.ebuild b/dev-python/termcolor/termcolor-2.2.0.ebuild
new file mode 100644
index 000000000000..987b49d298af
--- /dev/null
+++ b/dev-python/termcolor/termcolor-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI Color formatting for output in terminal"
+HOMEPAGE="
+ https://github.com/termcolor/termcolor/
+ https://pypi.org/project/termcolor/
+"
+# rename is for avoiding conflict with dev-cpp/termcolor
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> python-${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest