summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-07-13 09:04:09 +0200
committerSam James <sam@gentoo.org>2023-09-18 08:39:32 +0100
commit30a3a78fa90e8ffd70db65afb63d50edc367dcfb (patch)
tree5780bbb6d09b324612c1f397b98a1291c792532e /dev-python
parentdev-python/nextinspace: enable py3.12 (diff)
downloadgentoo-30a3a78fa90e8ffd70db65afb63d50edc367dcfb.tar.gz
gentoo-30a3a78fa90e8ffd70db65afb63d50edc367dcfb.tar.bz2
gentoo-30a3a78fa90e8ffd70db65afb63d50edc367dcfb.zip
dev-python/leechcorepyc: add 2.15.0
Closes: https://bugs.gentoo.org/906715 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/leechcorepyc/Manifest1
-rw-r--r--dev-python/leechcorepyc/leechcorepyc-2.15.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/leechcorepyc/Manifest b/dev-python/leechcorepyc/Manifest
index fdecfbba4520..12bc0962ad5c 100644
--- a/dev-python/leechcorepyc/Manifest
+++ b/dev-python/leechcorepyc/Manifest
@@ -1 +1,2 @@
DIST leechcorepyc-2.14.3.tar.gz 126511 BLAKE2B a15b593144685d1f44dc1b580c8146f57d6c784e39d2a4aad8b4221ea718ee79dffe24877ac74198a2f8baeaca30a37d3fe1e6680265b94bcc30dc7117002706 SHA512 06c4c66cc92c2c55e2dd2e57e5488a1864dc21a1667b4b39237372e95fcd6b99b569754a44eea7afdae32207245016b096939c0edf11a4133fc24a343c892ba8
+DIST leechcorepyc-2.15.0.tar.gz 176764 BLAKE2B d0e4aa14d0cc1ce1ad3c14e704949c3b872b0889449ca81c9ac8642340b301ce52baf638ce58a6c3d1262f0cfe5cc5ec8eb26f80d01d87933c33a0f87ac46338 SHA512 d1d5f775d4166b510dd110dfe3e28179464170682d3092e7887fd7464fef21c2e2d1bb6d2294eb8ab45cb2566df15f0bf3254d098afd8bcb6b36186517496bd2
diff --git a/dev-python/leechcorepyc/leechcorepyc-2.15.0.ebuild b/dev-python/leechcorepyc/leechcorepyc-2.15.0.ebuild
new file mode 100644
index 000000000000..47dbd6d391cd
--- /dev/null
+++ b/dev-python/leechcorepyc/leechcorepyc-2.15.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 toolchain-funcs pypi
+
+DESCRIPTION="Python binding for LeechCore Physical Memory Acquisition Library"
+HOMEPAGE="https://github.com/ufrisk/LeechCore"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# leechcorepyc ships with a bundled version of the LeechCore library. So we
+# don't depend on the library here. But we must be aware this module doesn't
+# use the system library.
+DEPEND="virtual/libusb:="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.14.0-respect-CC.patch"
+)
+
+src_prepare() {
+ default
+
+ # Avoid redefining _FORTIFY_SOURCE. See #893824, #906715.
+ sed -i -e 's/ -D_FORTIFY_SOURCE=2 / /g' leechcore/Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+
+ distutils-r1_src_configure
+}