summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-11 07:14:15 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-11 07:14:15 +0100
commit382d03c76578d1831985b44834955d7fd438a343 (patch)
treebd2c3a8e73fc906e66147366acb1c17aaccd7d43 /dev-python
parentdev-python/trimesh: Bump to 3.19.4 (diff)
downloadgentoo-382d03c76578d1831985b44834955d7fd438a343.tar.gz
gentoo-382d03c76578d1831985b44834955d7fd438a343.tar.bz2
gentoo-382d03c76578d1831985b44834955d7fd438a343.zip
dev-python/cfn-lint: Bump to 0.73.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.73.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 1ceb4d8178e3..a4bb2bfc95e6 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,2 +1,3 @@
DIST cfn-lint-0.72.10.gh.tar.gz 3252485 BLAKE2B 34290170b4620f2f094d96ebb41cb9e5afb84fb2a0b26826cfa92cf8f73ad7e15d3ab0d38ce3ac81477f389480b36edcea26bfcb5246de8b1a5ea93b6b60ca3d SHA512 2ae9cb11956ba431c7282c3813c3f00cb4a3599a0d73f521f3880ed1f916cf0fb447a889db2ae44748be810b1e95a7709d18ac18f27b4dd3e762fa7bfd499d13
DIST cfn-lint-0.72.9.gh.tar.gz 3239001 BLAKE2B 935d07e58d12a7b95bb589523a9ef49c9f508386d58384e7b391442ef02e304e583d687fce0f8faf892049525d6e621670061ab96a124229de7fc94df3e3533e SHA512 bf83e4146d4f2951e670c07a3a0bb3ab212881af9687c16244cade18bac101468c35532516731f66a80708312a9ee33bc531be9a6b7fab671bf54d596886a523
+DIST cfn-lint-0.73.1.gh.tar.gz 3337094 BLAKE2B 0fd3ac1116f8d38ebc4eef04bca5a6f6970c270682941a820240180d5eaa5908a8320e4e2adb0f29fe132dd56215fb42377435099a3ccb95697cc2caaa391794 SHA512 efdc54f983f9b7200ee725a844a9d83674309c080fb62c63e02430eb81c2992c4232a42bbe34d7b7f4ecc5097403bd9d8bf55806876f83e4ba3993e62597b675
diff --git a/dev-python/cfn-lint/cfn-lint-0.73.1.ebuild b/dev-python/cfn-lint/cfn-lint-0.73.1.ebuild
new file mode 100644
index 000000000000..fdd280348c81
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.73.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.59.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}