summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2023-01-06 00:34:33 +0100
committerLouis Sautier <sbraz@gentoo.org>2023-01-06 00:34:33 +0100
commit394a1d705b25fab267fa4938d5d3b4aaab27569f (patch)
treec657f9644a10d5b2282a96f667c729afda47f926 /dev-python
parentdev-qt/qtwebengine: add 6.4.2 (diff)
downloadgentoo-394a1d705b25fab267fa4938d5d3b4aaab27569f.tar.gz
gentoo-394a1d705b25fab267fa4938d5d3b4aaab27569f.tar.bz2
gentoo-394a1d705b25fab267fa4938d5d3b4aaab27569f.zip
dev-python/wand: add 0.6.11
Closes: https://bugs.gentoo.org/888499 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wand/Manifest1
-rw-r--r--dev-python/wand/wand-0.6.11.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/wand/Manifest b/dev-python/wand/Manifest
index ed0d00d96ab1..a0f5c54c4125 100644
--- a/dev-python/wand/Manifest
+++ b/dev-python/wand/Manifest
@@ -1 +1,2 @@
DIST Wand-0.6.10.tar.gz 11885159 BLAKE2B 206a652fa87a69f4d7af6156b2dc2b0ff515f317f9ad3d938ee15e50043ab3e3ffc052e0650ebfb2e5f5c5d1d1f1500f4880578a6cd7765d6c3af02f877fd843 SHA512 bde72e0ec56898c0885e483ec8dafc5dd2fbc1319736b5d46074cb00d1643c5368fbf66e0c8ff918dbe4b7b6ac4901551ee2c8563317c90c269e7ccfe53edf6f
+DIST Wand-0.6.11.tar.gz 11883567 BLAKE2B 561bcf6645f6eb41737c5e999f01e2719b5170d6e662e3812b4bd444fa77331175a22eff95eeb94ce17ecbe6dbef9a97e9a4f509f878431b64b357843fb15061 SHA512 4e551c2942835872f52247c2d642faf2ad4bad6bb206376e4f8dc5cdabe981e73b7e0f58a705d5dcbf8f95c445ed13bbe6b8443b9b29d0056e7aaf50565a608d
diff --git a/dev-python/wand/wand-0.6.11.ebuild b/dev-python/wand/wand-0.6.11.ebuild
new file mode 100644
index 000000000000..a7c1e7ca5dd4
--- /dev/null
+++ b/dev-python/wand/wand-0.6.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P^}
+DESCRIPTION="Ctypes-based simple ImageMagick binding for Python"
+HOMEPAGE="
+ https://docs.wand-py.org/
+ https://github.com/emcconville/wand/
+ https://pypi.org/project/Wand/
+"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-gfx/imagemagick
+"
+BDEPEND="
+ test? (
+ media-gfx/imagemagick[fftw,jpeg,png,truetype,xml]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ # PDF support is blocked by the default ImageMagick security policy
+ epytest --skip-pdf
+}