summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-16 06:35:25 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-16 07:04:51 +0200
commit39baf9f10e0cf5d4bff8972ed92751e351217c5b (patch)
tree371dff8f1cb69a0b7d1c6be8582952cd4ac94b80 /dev-python
parentdev-python/alembic: Bump to 1.11.0 (diff)
downloadgentoo-39baf9f10e0cf5d4bff8972ed92751e351217c5b.tar.gz
gentoo-39baf9f10e0cf5d4bff8972ed92751e351217c5b.tar.bz2
gentoo-39baf9f10e0cf5d4bff8972ed92751e351217c5b.zip
dev-python/ansible-compat: Bump to 4.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ansible-compat/Manifest1
-rw-r--r--dev-python/ansible-compat/ansible-compat-4.0.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index be5d0b0dc67b..00a8554ba071 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -3,3 +3,4 @@ DIST ansible-compat-3.0.2.tar.gz 63328 BLAKE2B d09ae255e08531b26f8cac7082a3ad0cc
DIST ansible-compat-4.0.0.tar.gz 62675 BLAKE2B 9c384a25729c2c1f72e806b4df6172e183cd8f62c91047b5862a581227554e980b00e58be99b9d4192f4d85d7ce53f1bc16d136762c9b71100f1aa3fdafa8cab SHA512 78559c0323ec190acf5e736a51b27349528eaeacd7fafbe953bbb9f03029985c514042ba9102117714ac5c558f50ac6e596da48c2fe491a092bd5d92c612fbb5
DIST ansible-compat-4.0.1.tar.gz 63728 BLAKE2B 51b6956059394e1e29d416113f6a924032cc6435780265c2595f1b0776477727c865c74afa25fc2527777a5d8ea74aead086293934cdc099966b875a96c5789f SHA512 a2edc46a472e6f99cd0231e453742780c5ae8713768bfda4218ae3d6979c38779ba8c5ec491813550a6b3242ef04e5de2c916c9538fcf5b018e7500fdf18bc4d
DIST ansible-compat-4.0.2.tar.gz 63771 BLAKE2B bcf66825c52de63172f7d36b696e136cc203201743e482d1aa78033664de49120a1304c6397e28dc56205fbe1b5f382f86852bc735cd879151df1db3ebaa1c1b SHA512 6332e12dc123bea6307a5306bb44357507e8c60f5699e8a09a39f9cfe44c649cfd8150b3a4687b47bc62bd95a7bdc4801cac01e10870df451f23ac2e278414e5
+DIST ansible-compat-4.0.4.tar.gz 65116 BLAKE2B 3f96e052cb9ba0352884fe1cfeacf9a1e5a7bbee715d08c054df49112966751067eb08f32b0598a8559e200fa9c3a619b58b854699342b6185bd9579bc75cbf2 SHA512 b13bc3d7a29b2caebfddb7a2311bfb8ad94062019238ed5a8a22fe9de1c00d25426694755cdbf289094db7fdfd88248fcf3e17e9aef9601046ef33c25d6894e6
diff --git a/dev-python/ansible-compat/ansible-compat-4.0.4.ebuild b/dev-python/ansible-compat/ansible-compat-4.0.4.ebuild
new file mode 100644
index 000000000000..bbea175e5664
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-4.0.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+)
+
+distutils_enable_tests pytest