summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-09 12:04:57 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-09 12:04:57 +0200
commit42477d3299cfe2512b95353b02481d430a30a208 (patch)
treef23df166e17b67114880c28d06077302d371f3e6 /dev-python
parentapp-arch/lz4: Remove old (diff)
downloadgentoo-42477d3299cfe2512b95353b02481d430a30a208.tar.gz
gentoo-42477d3299cfe2512b95353b02481d430a30a208.tar.bz2
gentoo-42477d3299cfe2512b95353b02481d430a30a208.zip
dev-python/pydantic: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pydantic/Manifest1
-rw-r--r--dev-python/pydantic/pydantic-1.10.1.ebuild77
2 files changed, 0 insertions, 78 deletions
diff --git a/dev-python/pydantic/Manifest b/dev-python/pydantic/Manifest
index 1d7121b0583e..b8a0f2569946 100644
--- a/dev-python/pydantic/Manifest
+++ b/dev-python/pydantic/Manifest
@@ -1,2 +1 @@
-DIST pydantic-1.10.1.gh.tar.gz 887019 BLAKE2B 5ca8d11528c7a7666136224c97dd0b078cf6f936a23227aa9dcd62af3c6a0af8f07c4c92751bd2c203497a626d4f93a78fd594bfc71dd0c43886c2dacc257af4 SHA512 2be3f10a82d655a94b3f250ed4c78439b4195dde3f7f6aa66028105b5c9b0e56aa8176701d563e5372533ae34e0b6d0fe2254df9429b04815607bcfc94e40370
DIST pydantic-1.10.2.gh.tar.gz 888288 BLAKE2B 9aac69ace185ccc56255cf36f9af472caf4c6bcbdcbb81eec66353f755673e9a240e7713c0a2ecff00a02e07b0069e4b3f1edda41f345698a979b79dd54b354a SHA512 dc2acfb271cd62b6de08bbaa48dbc76ec8d3a3f3142778ffa2cb9a2a1cad62dbdb3c7470a50e9a2825837b65a48c6aefb8736411f32c398aa9ca779841b53ac5
diff --git a/dev-python/pydantic/pydantic-1.10.1.ebuild b/dev-python/pydantic/pydantic-1.10.1.ebuild
deleted file mode 100644
index 4d31d79722de..000000000000
--- a/dev-python/pydantic/pydantic-1.10.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-MY_P=${P/_beta/b}
-DESCRIPTION="Data parsing and validation using Python type hints"
-HOMEPAGE="
- https://github.com/pydantic/pydantic/
- https://pypi.org/project/pydantic/
-"
-SRC_URI="
- https://github.com/pydantic/pydantic/archive/v${PV/_beta/b}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/typing-extensions-4.1.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/python-dotenv[${PYTHON_USEDEP}]
- >=dev-python/python-email-validator-1.2.1[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/CFLAGS/d' setup.py || die
- distutils-r1_src_prepare
-}
-
-python_compile() {
- if [[ ${EPYTHON} == pypy3 ]]; then
- # do not build extensions on PyPy to workaround
- # https://github.com/cython/cython/issues/4763
- local -x SKIP_CYTHON=1
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_mock
-
- local EPYTEST_DESELECT=(
- # flaky test, known upstream
- tests/test_hypothesis_plugin.py::test_can_construct_models_with_all_fields
- )
- case ${EPYTHON} in
- pypy3)
- EPYTEST_DESELECT+=(
- tests/test_private_attributes.py::test_private_attribute
- tests/test_private_attributes.py::test_private_attribute_annotation
- tests/test_private_attributes.py::test_private_attribute_factory
- tests/test_private_attributes.py::test_private_attribute_multiple_inheritance
- tests/test_private_attributes.py::test_underscore_attrs_are_private
- )
- ;;
- esac
- rm -rf pydantic || die
- epytest
-}