summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-26 08:46:50 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-26 08:50:34 +0100
commit42bec88bcc6b2db282e2cf3d44e078419260cbce (patch)
tree44bd60607e6208f39d92682e5ac5a1a817b89ee6 /dev-python
parentdev-python/starlette: Bump to 0.43.0 (diff)
downloadgentoo-42bec88bcc6b2db282e2cf3d44e078419260cbce.tar.gz
gentoo-42bec88bcc6b2db282e2cf3d44e078419260cbce.tar.bz2
gentoo-42bec88bcc6b2db282e2cf3d44e078419260cbce.zip
dev-python/python-socks: Bump to 2.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-socks/Manifest1
-rw-r--r--dev-python/python-socks/python-socks-2.6.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
index 5bcd1a809ba3..94edf03b58b8 100644
--- a/dev-python/python-socks/Manifest
+++ b/dev-python/python-socks/Manifest
@@ -1 +1,2 @@
DIST python-socks-2.5.3.gh.tar.gz 32399 BLAKE2B 39360537311683cb4ec6d1d9850e51877ab9d5f2319d83eefbee7362af1d0061bf7fba0fea9ebc74d24b9fab3a46ba78722ca4629c783406e935758f393d8183 SHA512 fd6351adf611e019298d2885d97d4ecdf1b9c9160297621d61bc770568eb5e20652507c7590b72de11e1e7505a60326139329d979ae325cba4abc81947ad6189
+DIST python-socks-2.6.0.gh.tar.gz 32596 BLAKE2B f68032b98c0689d2d7b9bcb581be9b6aa08fcf7b2813427a8acb6eb291d817a54ffbaa8ecac7a114d47ffc30ce4f9ea940e9bba0310f22950b8c1d129e1df167 SHA512 88d9d4e5166ddeceae66b3c61d89f25f099a89aba87f5524cd414b176f7d0eebe51f8d5ec2d98db683504bfd4936aec50f3354fafad97b587a687d49e21ad6f0
diff --git a/dev-python/python-socks/python-socks-2.6.0.ebuild b/dev-python/python-socks/python-socks-2.6.0.ebuild
new file mode 100644
index 000000000000..6e7cdd24fd84
--- /dev/null
+++ b/dev-python/python-socks/python-socks-2.6.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://github.com/romis2012/python-socks/
+ https://pypi.org/project/python-socks/
+"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# curio is not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+# TODO: revisit
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-4.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/tiny-proxy-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.24[${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+# Test markers exist to exclude trio etc if needed
+distutils_enable_tests pytest