summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-05 13:10:20 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-05 13:10:20 +0200
commit4644ff18014566d65fdbda87b8fafd6f76b24a99 (patch)
tree4f1a2013e07ccbd796f77ebf67bccd77b973febb /dev-python
parentdev-python/deprecation: Port to py3.10 (diff)
downloadgentoo-4644ff18014566d65fdbda87b8fafd6f76b24a99.tar.gz
gentoo-4644ff18014566d65fdbda87b8fafd6f76b24a99.tar.bz2
gentoo-4644ff18014566d65fdbda87b8fafd6f76b24a99.zip
dev-python/google-api-python-client: Eliminate unittest2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.11.0.ebuild7
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.8.0.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.11.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.11.0.ebuild
index 53fb37378258..08eb44b4eda8 100644
--- a/dev-python/google-api-python-client/google-api-python-client-2.11.0.ebuild
+++ b/dev-python/google-api-python-client/google-api-python-client-2.11.0.ebuild
@@ -32,11 +32,16 @@ BDEPEND="
dev-python/oauth2client[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
dev-python/parameterized[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
)"
distutils_enable_tests --install pytest
+src_prepare() {
+ find tests -name '*.py' -exec \
+ sed -i -e 's:unittest2 as ::' {} + || die
+ distutils-r1_src_prepare
+}
+
python_test() {
local deselect=(
# require Internet access (and credentials)
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.8.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.8.0.ebuild
index 69b970850c57..e52f1f75567e 100644
--- a/dev-python/google-api-python-client/google-api-python-client-2.8.0.ebuild
+++ b/dev-python/google-api-python-client/google-api-python-client-2.8.0.ebuild
@@ -32,11 +32,16 @@ BDEPEND="
dev-python/oauth2client[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
dev-python/parameterized[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
)"
distutils_enable_tests --install pytest
+src_prepare() {
+ find tests -name '*.py' -exec \
+ sed -i -e 's:unittest2 as ::' {} + || die
+ distutils-r1_src_prepare
+}
+
python_test() {
local deselect=(
# require Internet access (and credentials)