summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-07 03:47:42 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-07 03:47:42 +0200
commit488d42afe673cff546fec78848db944a8308ccbd (patch)
treeeb9c88b852bf9ad049187e31dc22347ff9860f7d /dev-python
parentdev-python/truststore: Remove old (diff)
downloadgentoo-488d42afe673cff546fec78848db944a8308ccbd.tar.gz
gentoo-488d42afe673cff546fec78848db944a8308ccbd.tar.bz2
gentoo-488d42afe673cff546fec78848db944a8308ccbd.zip
dev-python/truststore: Bump to 0.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/truststore/Manifest1
-rw-r--r--dev-python/truststore/truststore-0.9.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/truststore/Manifest b/dev-python/truststore/Manifest
index cc83e56ea705..7475de894309 100644
--- a/dev-python/truststore/Manifest
+++ b/dev-python/truststore/Manifest
@@ -1 +1,2 @@
DIST truststore-0.9.0.gh.tar.gz 26618 BLAKE2B f3d26a863e2810f620bc565eb819f8c113d9746f30869d2d7c1310f317b846f97525d7437fcf511ffaa28b622112604426f4e02655cbe5af1096b0c19dd39ece SHA512 b0af8bb3688c387c521b722c84ce7b5660238d7919eca76dd60f3dfe3bd6484c6e005125975b326eae2824a96120693536f8047980feae4c3aaed443870705ea
+DIST truststore-0.9.1.gh.tar.gz 26720 BLAKE2B e5bf3905367f75cdfd9314f1c544f004e62c2ddcde97f83bfe5ddc2d7606d44df5fc352811c8c42423be2da46e5f7b9642a2aeebe61436669c4cd9265ddbec96 SHA512 38567198a3b0d4e9c0b3df72674f3e1fef0614ef0afa80bd7276f98c2e7ef2dc00cca92184b80a1dfe535c5d2508ebdb775e389576c2f07536838f67de1958ca
diff --git a/dev-python/truststore/truststore-0.9.1.ebuild b/dev-python/truststore/truststore-0.9.1.ebuild
new file mode 100644
index 000000000000..6f5193f91dbe
--- /dev/null
+++ b/dev-python/truststore/truststore-0.9.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Verify certificates using native system trust stores"
+HOMEPAGE="
+ https://github.com/sethmlarson/truststore/
+ https://pypi.org/project/truststore/
+"
+SRC_URI="
+ https://github.com/sethmlarson/truststore/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+# The vast majority of tests require Internet access.
+PROPERTIES="test_network"
+RESTRICT="test"
+
+BDEPEND="
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p pytest_httpserver
+}