summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-24 10:16:33 +0000
committerSam James <sam@gentoo.org>2024-12-24 10:20:20 +0000
commit4a4b79ae21f853960d682596e081d80bd66a4717 (patch)
tree884a83d7106d299065af9bb25fd8b4b5339a523c /dev-python
parentmedia-plugins/gst-plugins-zbar: add 1.22.12 (diff)
downloadgentoo-4a4b79ae21f853960d682596e081d80bd66a4717.tar.gz
gentoo-4a4b79ae21f853960d682596e081d80bd66a4717.tar.bz2
gentoo-4a4b79ae21f853960d682596e081d80bd66a4717.zip
dev-python/gst-python: add 1.22.12
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gst-python/Manifest1
-rw-r--r--dev-python/gst-python/gst-python-1.22.12.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/gst-python/Manifest b/dev-python/gst-python/Manifest
index 670eba39788d..4c7dec33af1c 100644
--- a/dev-python/gst-python/Manifest
+++ b/dev-python/gst-python/Manifest
@@ -1 +1,2 @@
DIST gst-python-1.22.11.tar.xz 118072 BLAKE2B 7133bdc6462ed54669b18f0650ec9e9d5c90d406eadedccc2f125c01b05366c8cfd89ae17178a8197fd4c251d53fd848bdb498ff377076e402983a404f16c186 SHA512 749a3080ad56edfee66c6f24ab106b07cd2a7d6e5f704147a69e12fc0a1da9d9b8d8337c36ce62af459577df3f0804c60cbeb4a211454277ad0a46fd89edcfa5
+DIST gst-python-1.22.12.tar.xz 118924 BLAKE2B 0d31f86e2b2e673da545c94f7f4b5f934614d4cf906b96844fbfecb0cf8d6af3d85fbf197477d534f2d72248e048b945c4b974b5239e4ae68951428e016526e3 SHA512 27cd724a21d66a6c3827e3cbaeeb70f15af5253763c1410990232cb550a363a7c61ff076771fdad94f31026ad70b051d2b1ef180bbab92e2e456ae4ce467223f
diff --git a/dev-python/gst-python/gst-python-1.22.12.ebuild b/dev-python/gst-python/gst-python-1.22.12.ebuild
new file mode 100644
index 000000000000..50e860486672
--- /dev/null
+++ b/dev-python/gst-python/gst-python-1.22.12.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit meson python-r1 xdg-utils
+
+DESCRIPTION="A Python Interface to GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=media-libs/gstreamer-${PV}:1.0[introspection]
+ >=media-libs/gst-plugins-base-${PV}:1.0[introspection]
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # Avoid building & testing plugin - it must NOT be multi-python as gst-inspect will map in all libpython.so versions and crash or behave mysteriously.
+ # Python plugin support is of limited use (GIL gets in the way). If it's ever requested or needed, it should be a
+ # separate python-single-r1 media-plugins/gst-plugins-python package that only builds the plugin directory.
+ sed -e '/subdir.*plugin/d' -i meson.build || die
+ sed -e '/test_plugin.py/d' -i testsuite/meson.build || die
+
+ xdg_environment_reset
+}
+
+src_configure() {
+ configuring() {
+ meson_src_configure \
+ -Dpython="${EPYTHON}"
+ }
+ python_foreach_impl configuring
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_test() {
+ python_foreach_impl meson_src_test
+}
+
+src_install() {
+ installing() {
+ meson_src_install
+ python_optimize
+ }
+ python_foreach_impl installing
+}