summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-24 07:01:22 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-24 08:00:29 +0200
commit5124f87e11b6684bcefc4318ef418a25524c4f59 (patch)
treee3919c7d3a05c7d36a6437704ce9f4431c96fa84 /dev-python
parentdev-python/pygdbmi: Stabilize 0.11.0.0 arm64, #935906 (diff)
downloadgentoo-5124f87e11b6684bcefc4318ef418a25524c4f59.tar.gz
gentoo-5124f87e11b6684bcefc4318ef418a25524c4f59.tar.bz2
gentoo-5124f87e11b6684bcefc4318ef418a25524c4f59.zip
dev-python/pytest-subprocess: Bump to 1.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-subprocess/Manifest1
-rw-r--r--dev-python/pytest-subprocess/pytest-subprocess-1.5.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pytest-subprocess/Manifest b/dev-python/pytest-subprocess/Manifest
index 50d817de0d37..3663c39be750 100644
--- a/dev-python/pytest-subprocess/Manifest
+++ b/dev-python/pytest-subprocess/Manifest
@@ -1 +1,2 @@
DIST pytest-subprocess-1.5.0.gh.tar.gz 34771 BLAKE2B b76ab9234ff2ec437ef9679c2e8af6cdc545189c7fd9f832f68c5cad094c80250c5fe1fd6e0da54d7a8c09da30a66f7f097da66f03d169e149186b49e2b72b56 SHA512 8489993cc396d41d127927ab46a43120528dbcb9641e7be03777689af127df29fe618eee3a815e96a0353cc02117dc1af22800d748476c4fe2b76c2246229f08
+DIST pytest-subprocess-1.5.1.gh.tar.gz 35269 BLAKE2B a614376eb25b0e58fe438f2bfc2033ebdb4e83a34cc4fd2ef68b162830dadc2ec4eea436abdcf7d88591ade57e05dd2dcdfbb6443ae30549a03aa9c0935afeeb SHA512 1b719a6d3d1a38638490d574f2b3f9b8a6b76f4059fd05f8c7230395db34caf5e34e58a977ad47a779e65b77317bc05af1293378bca84469fdf205822fbc1cdc
diff --git a/dev-python/pytest-subprocess/pytest-subprocess-1.5.1.ebuild b/dev-python/pytest-subprocess/pytest-subprocess-1.5.1.ebuild
new file mode 100644
index 000000000000..f178708bfd6b
--- /dev/null
+++ b/dev-python/pytest-subprocess/pytest-subprocess-1.5.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A plugin to fake subprocess for pytest"
+HOMEPAGE="
+ https://github.com/aklajnert/pytest-subprocess/
+ https://pypi.org/project/pytest-subprocess/
+"
+SRC_URI="
+ https://github.com/aklajnert/pytest-subprocess/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/anyio[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.12[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.15.1[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # https://github.com/aklajnert/pytest-subprocess/pull/162
+ sed -i -e '/py_modules/d' -e '/find_packages/d' setup.py || die
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_subprocess.fixtures,pytest_asyncio.plugin
+ epytest -p rerunfailures
+}