summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-13 06:02:50 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-13 06:02:50 +0200
commit56bb4552fb3f66a1131394aac2134ee8b0610ebc (patch)
tree6865916132530f4cca77dcd5a909d95142173857 /dev-python
parentdev-python/openapi-core: Bump to 0.19.2 (diff)
downloadgentoo-56bb4552fb3f66a1131394aac2134ee8b0610ebc.tar.gz
gentoo-56bb4552fb3f66a1131394aac2134ee8b0610ebc.tar.bz2
gentoo-56bb4552fb3f66a1131394aac2134ee8b0610ebc.zip
dev-python/pyspnego: Bump to 0.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyspnego/Manifest1
-rw-r--r--dev-python/pyspnego/pyspnego-0.11.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyspnego/Manifest b/dev-python/pyspnego/Manifest
index 1778f3675e87..22851058fad9 100644
--- a/dev-python/pyspnego/Manifest
+++ b/dev-python/pyspnego/Manifest
@@ -1 +1,2 @@
DIST pyspnego-0.10.2.tar.gz 222036 BLAKE2B b46c5469e7f764342f1510d54ee307ec57c6d999d2beb013fdc18eb06d56d601b3f035f0a9d9f9f5a656719f19a345ee25ca8664084afac3dd42529ae53dcf4a SHA512 9d5b45a9c4c2c929269f5eceaa05fbe34571e518b289b165049ddb7fd2bb207c7e6074c45216ad0cdf20e4be7bfca2f3d497aba45e2aadceb0b75221edc54f5d
+DIST pyspnego-0.11.0.tar.gz 225609 BLAKE2B 580ba1eb5a36af973af5acd6421ea373597961fe35e8f32c1cdd7938f550e0e20307a540405182761181927ebb69822dd289170ffe5110a8b49bfc4cc4f99f01 SHA512 7717dfbca4cd40f71f6aa436ed3f23f4cfd77c50569af90dd2f4b337cf46b485b8046fc5b2ded6a77c54af2ef3fca28e085616e900e25d8830b3600cbd3e44b5
diff --git a/dev-python/pyspnego/pyspnego-0.11.0.ebuild b/dev-python/pyspnego/pyspnego-0.11.0.ebuild
new file mode 100644
index 000000000000..d4c182cc408c
--- /dev/null
+++ b/dev-python/pyspnego/pyspnego-0.11.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Library to handle SPNEGO and CredSSP authentication"
+HOMEPAGE="
+ https://github.com/jborean93/pyspnego/
+ https://pypi.org/project/pyspnego/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/gssapi[${PYTHON_USEDEP}]
+ >=dev-python/krb5-0.3.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "Kerberos authentication" "dev-python/gssapi >=dev-python/krb5-0.3.0"
+ optfeature "YAML output support" "dev-python/ruamel-yaml"
+}